0
Answered

Prestashop not redirecting to correct CMS page

VAULT 4 years ago in Ecommerce / Prestashop 15 0
Hi,

Inmotion has really screwed me over this time. I requested a website back up to a save from before this was a problem and they couldn't back up to it because they didn't stop the automatic back up system from writing over my previous back up. So I have no other way to fix this than help from my fellow community members.
I am receiving this error: [Thu May 12 18:23:20.599594 2016] [:error] [pid 150961:tid 140643388335872] [client 98.27.1.154:62545] Failed loading /opt/php56/lib/php/extensions/no-debug-non-zts-20131226/: /opt/php56/lib/php/extensions/no-debug-non-zts-20131226/: cannot read file data: Is a directory, referer: https://www.***********.com/index.php?controller=warranty

I have no idea what this means as I am quite new to Prestashop. Can anyone offer some insight?

Thanks,
Zack
Hello Zack, Thank you for your question regarding PrestaShop not redirecting to the correct CMS page. I definitely understand your frustration. Since redirects are often controlled by .htaccess rules, renaming your .htaccess file is a good first step. I always recommend enabling error reporting in PrestaShop any time you are troubleshooting issues, as it may provide additional error details. Since these seem like a PHP related errors try renaming your php.ini file, which will cause your site to use the default server settings. Next, try changing your PHP version, such as switching to PHP 5.4. Also, review what you were working on when this problem started occurring. For example, if you edited some code, or installed a plugin, try removing it. Instead of relying on the emergency backups, I highly recommend performing a backup before making any untested changes to your live site. You can create a complete cPanel backup, partial backups (of your site files/database), or even backups via Softaculous at any time. Best Regards, John-Paul