Fixing the jQuery version in osCommerce

jQuery Errors osCommerce 2.3.3

When installing the Theme Switcher on your osCommerce site, you will encounter errors regarding the jQuery files not being found. Please see the snapshot to the right. This is because when the osCommerce was released, the version was changed. This article will explain how to update your osCommerce to the newest version of jQuery.

The versions of jQuery at the time of this article are the jQuery 1.9.1 and the jQuery UI 1.10.2.

Steps to update your osCommerce jQuery

First you will need to get the newest versions of jQuery. Below are the steps to update the newest versions of jQuery and jQueryUI.

jQuery 1.9.1

  1. Download the newest version (at this time 1.9.1) from the link below:

    jQuery

  2. You should have a file named jquery-1.9.1.min.js on your desktop.

    Upload the file to the following directory in your osCommerce installation.

    /ext/jquery/

jQueryUI 1.10.2

jQuery Errors osCommerce 2.3.3

Next you will need to get the jQueryUI files. Download the newest jQueryUI (At this time 1.10.2) from the link below

jQueryUI

Select 1.10.2 and select the Redmond theme from the drop box and click download. See image to the right. When you download the .zip file you should have a file named jquery-ui-1.10.2.custom.

  1. You will need extract the files on your local computer, open the folder and rename the following file:

    /development-bundle/themes/redmond/jquery-ui.css

    Rename to:

    /development-bundle/themes/redmond/jquery-ui-1.10.2.css

  2. Next, rename the the following file in the jQueryUI files on your computer.

    /js/jquery-ui-1.10.2.custom.min.js

    Rename to:

    /js/jquery-ui-1.10.2.min.js

  3. Upload the /development-bundle/themes/redmond folder to your server in the following location on your server.

    /ext/jquery/ui

Configuring the Theme Switcher

  1. Log into your osCommerce Administrative Dashboard.
  2. Configure Theme Switcher osCommerce 2.3.3

    Go to Modules > Header Tags on the right. Select the Theme Switcher module and click edit at the top of the module interface.

    When the screen loads you will see the default jQuery values in the “Jquery Version” and “Jquery UI Version” box. See image to the right.

    Changed values osCommerce 2.3.3

    Change the Values to the new jQuery versions. See image to the right.

    Click Save.

    Good to go green osCommerce 2.3.3

    Now the red errors will be gone. If you still see the red errors, its because you did not rename the files correctly or you uploaded the files in the wrong location.

Thoughts on “Fixing the jQuery version in osCommerce

  • Fatal error: ‘break’ not in the ‘loop’ or ‘switch’ context in …/store/includes/modules/header_tags/ht_theme_switcher.php on line 415

    Here is an error could you please explain and assist with it.

     

    • As far as you can tell, what caused the error? I suspect it is caused by the PHP version. Did you recently upgrade your PHP configuration or the CMS?

  • This error is not remove please help me ??      

    above code is not helped to remove this error ?

     The theme CSS file is the wrong version or missing!”. 

     

    • Hello Sheikhoo,

      Can you please provide your URL so we can investigate the issue at hand? Have you also made sure that your CSS files are included in the theme pages?

      Best Regards,
      TJ Edens

  • Thanks for the instructions. I was able to follow most of it except Step 2 of the jQueryUI 1.10.2 instructions (above). The instructions ask that the file – /js/jquery-ui-1.10.2.custom.min.js be renamed to
    /js/jquery-ui-1.10.2.min.js . Once the file is renamed, then what? I don’t see any instructions indicating where it should be uploaded to. I’ve tried uploading to a couple of spots but keep getting an error message in the Header Tag Module, “ The theme CSS file is the wrong version or missing!”.

    Any and all help appreciated.

    Thank you.

    • Hello John,

      The location for the file to be loaded are in the first box above (step 2) – Upload the file to the following directory in your osCommerce installation.

      /ext/jquery/

      I hope this helps to answer your question, please let us know if you require any further assistance.

      Regards,
      Arnel C.

  • Carefully followed the directions – the ecommerce installation now has only half of the left column navigation visible – clicked on modules just takes me to a general information screen – no mudules.

    Oh dear.

    • Hello Mike, sorry to hear that you’ve encountered some problems with your osCommerce shop.

      Unfortunately it would be a bit hard for us to troubleshoot your issues without seeing it ourselves. If you’d like to comment back on this article with the website you’re having these issues on we can take a look and remove your domain name from the post before making it public.

      This guide is over a year old, and there have been many updates to jQuery since then, so that could possibly be causing an issue. What version of osCommerce are you running on your website, and which version of jQuery?

      – Jacob

Leave a Reply