Should I upgrade Joomla 2.5 to Joomla 3.0?

The latest news announcement from the Joomla team says that those of us running Joomla 2.5 on a server shouldn’t update to Joomla 3.0. It’s recommended instead to wait for the next long-term-support release version, which will be Joomla 3.5.

click-update-now

If you’re familiar with the update tool in Joomla 2.5, you should not expect to see the 3.0 update listed.

If you do upgrade to Joomla 3.0, you’ll want to make sure you upgrade to Joomla 3.1 and Joomla 3.5 when those releases are public.

Be aware that not everyone will be able to upgrade from Joomla 2.5 to 3.0. For example, if you use a component on your site that has not yet been upgraded to Joomla 3.0, then an upgrade may not be a viable option.

If you can’t upgrade from Joomla 2.5 to Joomla 3.0, don’t worry just yet. Joomla 2.5 is referred to as a long-term-support release, meaning that we can expect it to be supported at least to September of 2013.

 

Leave a Reply