Moodle Requires PHP 5.3.2 – Work Around

Users of Moodle 2.1 and higher versions may experience an issue when attempting to install Moodle (using Fantastico or manually). Users who install Moodle through Fantastico are able to complete the installation but will see a blank white screen when attempting to log in. Users who attempt to install Moodle manually, will receive an error that Moodle requires PHP version 5.3.2.

This is due to a mismatch in the required PHP version for Moodle 2.1 and higher. Currently, PHP 5.3 is not available on our servers. Unfortunately, upgrading to PHP 5.3 in a shared environment is not an option. This can potentially break other customers software they might be using to operate their websites. 

To use Moodle 2.1 please see our article:

Modifying the lib.php file in Moodle 2.1 versions and higher

Before making and changes, we do recommend creating a backup of your account. If you have any further questions please feel free to submit a question in your Community Support area

Leave a Reply