InMotion Hosting Support Center

Wordpress - some plugins get tmp directory or wrong permissions error

Category: Wordpress

200 Points
2013-10-15 5:36 pm EST

Hits: 7,597
i got this error on a diff plugin yesterday, which then i directly uploaded the plugin to the wp-content plugin directory and then activated it fine via the WP site back end. i thought it was only one time thing. now today a new plugin gets the same type of error. can you help me? (but to the same site i just tried to add new plugin Yoast Seo and it download into my site fine, what is going on?) thank you!

Installing Plugin: NextGEN Gallery 2.0.31
Downloading install package from…
Warning: touch() [function.touch]: Unable to create file /tmp/nextgen-gallery.tmp because No such file or directory in /home/xxxxxxx/public_html/ on line 179
Warning: unlink(/tmp/nextgen-gallery.tmp) [function.unlink]: Operation not permitted in /home/xxxxxxx/public_html/ on line 503

Download failed. Could not open handle for fopen() to /tmp/nextgen-gallery.tmp

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Edward P found a solution, but it works for only one site. i hope there is a way to FIX it so that this line of code doesn't have to be inserted to each WP site directory.



i can give you my sites but i'm not sure if i should post my primary account user id here?
200 Points
2013-10-15 06:11 pm EST
Hello TheBoatPeople,

Using the method I described below with a recursive php.ini file to define your temporary upload directory, it should work across all your sites.

- Jacob
9,968 Points
2013-10-15 06:17 pm EST i think Ed found the solution here
200 Points
2013-10-15 06:19 pm EST
Is there a fix for this problem? I'm getting the same problem over and over and this has never happened on my Wordpress site before.
0 Points
2014-03-02 03:09 am EST



9,968 Points
2013-10-15 6:11 pm EST
Hello TheBoatPeople, and thanks for your question,

Have you possible made your php.ini file recursive on your account? If you haven't done this already, you should be able to create a php.ini file specifying the directory that PHP should use to place temporary files on the server with this setting:

upload_tmp_dir ="/home/userna5/tmp/"

That way the server will utilize your own home directory's /tmp directory, instead of the server-wide one when doing things like saving WordPress plugins for installation from your dashboard.

If you're still having any issues at all, please let us know!

- Jacob

You must login before you can post a comment about this answer.

Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!