InMotion Hosting Support Center

Issues uploading images in WP

Category: Wordpress

InMotionFans
n/a Points
Asked:
2015-04-10 11:45 am EST

Hits: 2,152
I changed to your hosting a few days ago. Now I tried to upload a new picture to Media Library and I am not allowed to, get the following error comment:
Error expedition p…carena32.jpg Unable to create directory uploads/2015/04. Is its parent directory writable by the server?

I think it treats about permissions for uploads of images...might you please check that permissions for me in order to make that work?

So, I contacted your colleagues from tecnical support and they checked the server config, but told me that is not the problem. But to be true, before I never had issues running my site on godaddy servers, your team changed my website to your servers, and now uploads do not work anymore.
As your collegues from tech support couldn't help me out with a solution, they told me the following:

'You can also check with our Customer Community team, to see where else upload folder configuration may be changed. They are experts on using content management systems, and could provide more insight than Technical Support might - we only troubleshoot the hosting service, not site platforms.'

would be great if you can check that for me...

Thank you. Br, Alex

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

John-Paul
Staff
31,633 Points
2015-04-10 12:26 pm EST
Hello Alex,

Thank you for your question about uploading images in WordPress. I found many results for this error, so there are several things you can check. I found many people were able to upload successfully after specifying the upload folder in WordPress.

I know you attempted to check them already, but I want to include this information since most guides recommend checking your permissions. You can check view and modify your file/folder permissions at any time.

Enabling WordPress Debugging may provide a more detailed error message.

I have seen instances where Regenerating Thumbnails helped after migrating a WordPress site to our servers.

We also have a guide that explains Common WordPress Troubleshooting Techniques.

If you have any further questions, feel free to post them below.

Thank you,
John-Paul

You must login before you can post a comment about this answer.

Hey John-Paul, thanks for your quick reply....i checked permissions on cpanel's folders, they were set on 755, that should be ok, but to go sure, i changed to 777 and still not working...
The option to regenerate thumbnails i wanna keep up as last try, as i do not wanna loose my photos....
I enabled wordpress debuging in wp-config.php file, but i get no results at all shown in cpanels error log file....what might be the reason for that? so I have no more detailed info about the real error...
I cannot handle information given in article 'specifiying upload folder'.....
to be true, no idea what next step could be to get that fixed...
any ideas?
Alexro
9 Points
2015-04-10 1:23 pm EST
finally found the solution, no idea why that configuration changed just after website move to another hosting, but now it works, just that simple ;-) :
https://www.tipsandtricks-hq.com/how-to-fix-unable-to-create-directory-error-when-uploading-image-into-wordpress-557
Alexro
9 Points
2015-04-10 2:18 pm EST
Hello John-Paul,
it is getting more and more weird, as I wrote in my post before I could fix the problem with uploads in media gallery, now I can upload to media gallery. But now it appeared another problem: I am no more able to upload images from media gallery to my pages/posts. The 'good' images from media gallery appear with a 'broken' symbol....

there is an additional problem I just discovered....please look at following page:
http://www.travelombia.com/destinations/region-caribbean/
If you look into the translations (German and Spanish site) it should appear the same content, just in another language.
http://www.travelombia.com/de/destinationen/region-karibik/
http://www.travelombia.com/de/destinationen/region-karibik/

But most of the content doesn't show up, but if you go to edit section of this wordpress page, there the full content appears setup. Just don't show up life....
might that be connected to that problem maybe?
In general I am quite sure that this is connected to the move of my website to your hosting (before I had it in godaddy and everything was working fine). I would appreciate if you could check my file setup on the server, maybe problem is connected to .htaccess or wp-config.php file???? look, there is for example another file showing up named wp-config.php.20150407 .... is that the reason maybe? sometimes i got today the errormessage 'error establishing a database connection'....might this be the problem? remember, as i mentioned in message before, i could fix the media upload problem changing the following: In the Miscellaneous Settings put wp-content/uploads in the “Store uploads in this folder” text box. The part of the path before wp-content I deleted as described. maybe that doesn't fit anymore to database info in wp-config.php.
All in all, I am quite lost, and I would appreciate if you can help me to solve that problem, or give me a contact at inmotionhosting in order to check what went wrong with the move of my website (as your collegues did the move)....
Thanks in advance.
Br, Alex
Alexro
9 Points
2015-04-11 12:17 am EST
Hello Alex,

Typically transfers do not create issues with the sites. There may be specifics in the account that need to be taken care of. As the public Support Center deals with general error messages and troubleshooting you will want to contact the Live Support. This is due to the fact that we may need to ask for account specific information, which you will not want to have public.

Kindest Regards,
Scott M
scott
43,761 Points
Staff
2015-04-13 9:10 am EST
0

BusinessCoach
2015-05-14 1:48 pm EST
Hi Alex,

We ran into the same issue after migrating a few client sites over to inMotion. Your WordPress upload path may still be using your username from your old host and need to be changed to your cPanel username on inMotion.

We were able to resolve the issue by:
1) Logging into cPanel
2) Opening phpMyAdmin in the "Databases" section of cPanel.
3) In the left navigation, expand the drop down menu and choose the WordPress database for your site.
4) Look for the "wp_options" table in your database.
5) Within the "wp_options" table, click the edit button to change the "option _value" field for "upload_path" to:
/home/insert-your-cpanel-username-here/public_html/wp-content/uploads

Hope that helps.

You must login before you can post a comment about this answer.

Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!