InMotion Hosting Support Center

Gravity Forms Error msg: Upload folder not writable

Category: Wordpress

TEAM_Solutions
Asked:
2015-02-20 11:50 pm EST

Hits: 2,978
"Upload folder is not writable. Export and file upload features will not be functional." showed up after migration from godaddy to inmotion. Problem doesn't exist when Gravity Forms is deactivated. Inmotion's tech support has provided neither.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Go read my lengthy chat record concerning this issue.
TEAM_Solutions
14 Points
2015-02-20 11:53 pm EST

OTHER ANSWERS

0

scott
Staff
43,761 Points
2015-02-23 11:49 am EST
Hello,

Thank you for your question the non-writable error. Have you tried disabling and enabling the plugin to see if it resets the path? Have you tried to adjust the path by going to SETTINGS > MEDIA > Document Upload Directory?

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Yes. The error only appears when gravity forms is activated. GF said that they don't set permissions but helped me establish that the actual uploading of a file on a test form was successful, by the way.

No, have not adjusted any path. What settings? Where? Please be specific where and how to do that I will give a try. Thanks.
TEAM_Solutions
14 Points
2015-02-23 1:23 pm EST
Hello,

The SETTINGS > MEDIA > is found onthe left hand sidebar menu of your admin dashboard. The "Document Upload Directory" I can only assume is a setting placed by Gravity Forms since we do not have a copy to check for ourselves. The directions is information that I found in the WordPress forums regarding your error message.

Kindest Regards,
Scott M
scott
43,761 Points
Staff
2015-02-23 8:16 pm EST
The upload reference mentioned applies to all of wordpress, not just gravity forms. And the problem is a result of the failed migration to InMotion. Ergo, the solution resides somewhere within InMotion. Help please!
TEAM_Solutions
14 Points
2015-02-25 3:04 pm EST
0

mchartley
2015-05-20 4:28 am EST
I found a very simple fix - reactivate gravity forms - at that point go to settings - media - you will see the upload path that is being used by your installation. In my case it was still showing the upload path from the old server - I reset it to default and voila! No more problem with upload message.

You must login before you can post a comment about this answer.

Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!