InMotion Hosting Support Center

After Migrating Word Press Home page redirects to wp-admin/install.php

Category: Wordpress

Gilbert
Asked:
2016-02-24 1:09 pm EST

Hits: 8,813
Hi All,

Manually migrating my WP site to InMotion. I exported the old database via MyPHPadmin, exported files, created new database and username/password, uploaded SQL file to new database, moved files via FTP and updated PHPconfig file to reflect appropriate database and username/password.

After editing PHP config file, when visiting URL I get a redirect to wp-admin/install.php

Any troubleshooting advice appreciated!

Thanks,
Barry

You must login before you can ask a follow up question.

You must login before you can submit an answer.

I am suddenly having these same symptoms. I made some changes to my site a couple of weeks ago, but there was no problem. Today, a customer notified me he was having trouble and I found that trying to use the wordpress login redirected to the install.php. As I've been looking at it, it seems like every page of the site is now doing this redirect.

I looked at my database with MyPHPAdmin - and most of the normal WP tables appear to be missing. But nothing I've done would have done this. Googling all this, I see a others had this as a mystery problem too and there is a suggestion to reboot the webserver and the MySQL server.

Is there a way to do this on one of your shared servers? Is there another solution? My site is down, I urgently need help.
renegadeartglass
0 Points
2017-01-09 04:25 pm EST

OTHER ANSWERS

0

Arn
Staff
42,973 Points
2016-02-24 1:12 pm EST
Hello Gilbert,

Sorry for the problem with your WordPress site re-directing to the Install.php after migrating it. I took a close look at your installation files, including the database. What I found was that your database had a unique prefix. When I added this prefix to the wp-config.php file, it fixed the issue and the site loads up with no problem now. Please check it out. Make sure that you reset your permalinks if you're not using the default setting (save as default, then change back to your original permalink setting to reset permalinks). I hope that helps! If you have any further questions or comments, please let us know.

Regards,
Arnel C.


You must login before you can post a comment about this answer.

Great, thanks.
Gilbert
11 Points
2016-02-24 1:48 pm EST
Fantastic! That's interesting about the database will be aware of that in the future.

Thanks for the quick assist.
Gilbert
11 Points
2016-02-24 2:01 pm EST
Hi Gilbert,

You're very welcome! It's satisfying to find something quick and simple to fix a problem. :)

If you have any further questions or comments, please let us know.

Regards,
Arnel C.
Arn
42,973 Points
Staff
2016-02-24 2:32 pm EST
Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!