InMotion Hosting Support Center

"Add plugin" option missing from Wordpress dashboard

Category: Wordpress

2013-02-13 8:33 pm EST

Hits: 806
I have recently set up wordpress on my domain. I can access preinstalled plugins but the "Add plugin" is missing from the menu. I have admin account. Does this have something to do with wrong installation of wordpress? Do I need to reinstall wordpress. If so can I backup the content of my site and restore it on a new installation?

You must login before you can ask a follow up question.

You must login before you can submit an answer.



40,963 Points
2013-02-13 10:25 pm EST
Hello RB2013,

The only information I found on this issue is that if you installed Wordpress using the MULTI-SITE option, then you will need to login to the NETWORK administrator (Enable Plugins for Individual Site Administrators of a MS Wordpress install). The multisite installation is typically used to have multiple Wordpress installations under one database. This isn't always necessary. If you installed it that way and you're using Softaculous from the Cpanel, then go back into Softaculous and uninstall the current installation and re-install NOT using the multi-site option.

If you're still having an issue with the plugin button, then let us know. If you could provide a test URL, it would also help. If you want to keep the issue private, then please contact live technical support (available 24/7). All posts on the Customer Support center are open to the public.

If you have any further questions, please contact technical support or leave a comment at the bottom of the page.


Arnel C.

You must login before you can post a comment about this answer.

Like this Question?

Need more Help?


Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!