InMotion Hosting Support Center

Enabling OAuth Extension


MJarratt
Asked:
2012-10-01 5:51 pm EST

Hits: 3,676
Hello. I can't seem to enable OAuth. I have installed HTTP_OAuth using the PEAR package installer. I have tried adding extension=oauth.so to my php.ini. I have changed php versions (currently running 5.4.6). When I run a simple OAuth script, I still get this message: "Fatal error: Class 'OAuth' not found"

Anyone have ideas on how to correct this? Thanks for reading.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

Arn
Staff
42,973 Points
2012-10-01 8:07 pm EST
Hello MJarratt,

Apologies for the frustration. I checked with our tier2c techs here and they took a look at the issue. One of the things that may have been missing was the option to set the php.ini recursive for the site in .htaccess:

suphp_configpath /home/yourusername/path/to/php.ini


They added this line, but we're not sure what you're running to check on your code. If you could please check this, and then get back to us if it's not working.

If you have any further questions, please contact technical support or leave a comment at the bottom of the page.

Regards,

Arnel C.

You must login before you can post a comment about this answer.

Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!