InMotion Hosting Support Center

SSL certificate installation problem

Category: Ssl

alanchcw
Asked:
2015-05-15 7:15 pm EST

Hits: 339
Hi,

I purchased SSL EV sertification from Comobo (for domain mysite.com and www.mysite.com) and have InMotion staff installed it for my website https://www.mysite.com.

When I use browsers such as IE, FireFox to visit https://www.mysite.com, everything is OK and the green bar is displayed.

However, when I use wget to get a file from my website from the command line, like this:

wget https://www.mysite.com/myfile.exe

Then I will get an error said

ERROR: cannot verify www.mysite.com's certificate, issued by `...':
Self-signed certificate encountered.

Also when I receive emails via Outlook, I use server server.mysite.com, and will also get an error indicating "cannot verify the certificate" and I have to install the certificate for server.mysite.com each time.

I try to contact support of InMotion but they just ignore the error information included in my ticket. They just said IE and Chrome can visit the SSL site properly. Therefore, I have to post the question here.

Please advise.

Thanks

(To protect the privacy, I just replace my domain with www.mysite.com)

You must login before you can ask a follow up question.

You must login before you can submit an answer.

The Outlook warning can be found at http://www.msoutlook.info/question/613
alanchcw
21 Points
2015-05-15 07:17 pm EST

OTHER ANSWERS

0

Arn
Staff
42,973 Points
2015-05-15 7:48 pm EST
Hello Alanchcw,

Sorry for the issues with SSL certificate installation problem. The SSL certificate is installed correctly and it checks out with any SSL checker that we looked at online. When you're using WGET, it is typically disabled on InMotion hosting servers. Since you're on a dedicated server you can enable it. You can contact live support again through the ticket to explain what you're trying to do with WGET if you continue to have the problem, though, we would suggest using CURL instead.

In regards to email, by default VPS and Dedicated servers are using a self-signed certificate for email. If you don't want to approve the self-signed certificate, then you will continually be required to verify it every time you use email. You can properly setup the certificate for email using WHM.

If you have any further questions or comments, please let us know.

Regards,
Arnel C.

You must login before you can post a comment about this answer.

For email, I try to approve the self-signed certificate and install it. But next time when I restart Outlook, it will display the warning again. Why? Thanks
alanchcw
21 Points
2015-05-16 7:01 am EST
0

laiello
2015-05-17 7:51 am EST
It honestly sounds like the SSL was installed for the site, but not for other services (like mail). I would reach out to IMH's team to have them correct this.

As far as wget, it could be a multitude of causes, including lack of Certificate Chain.

The easiest workaround if you trust the site is to use the "--no-check-certificate" flag in your request so it will use SSL, but ignore any validity errors.
Example: "wget --no-check-certificate 'https://www.inmotionhosting.com'"

You must login before you can post a comment about this answer.

Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!