InMotion Hosting Support Center

'ERR_SSL_PROTOCOL_ERROR'; how to resolve.

Category: Ssl

schnickelfritz
Asked:
2014-10-30 12:11 pm EST

Hits: 5,747
I'm running WordPress and installed a program called Infinite WP (IWP) to manage multiple WP installations on different domains & hosting servers. I figured out how to access the IWP admin login page using IMH's shared SSL certificate. [In the browser, I called the secure server & my account user name in the browser.] When I enter my login credentials into IWP, I get rerouted from IMH's secure server url (https://secure158.inmotionhosting.com/~******16/iwp/login.php) to my personal account url where the IWP files are stored in a domain subdirectory (https://spiralwebdb.com/iwp/). The browser then throws the following error message: SSL Connection Error ( 'ERR_SSL_PROTOCOL_ERROR').

This might be a chicken or egg situation (Q: which came first?); is the problem caused by an error in the IWP files (either config.php or login.php)? Or does the problem lie with the web host, in terms of not having the proper authentications with the shared SSL certificate?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

John-Paul
Staff
30,497 Points
2014-10-30 12:53 pm EST
Hello schnickelfritz,

Thank you for your question about the 'ERR_SSL_PROTOCOL_ERROR'. If you are being redirected to another domain, its possible the domain is still setup as the URL somewhere.

Make sure you have Enabled https in WordPress.

Then updated the Wordpress site URL to reflect the shared SSL address.

I also checked the shared SSL with an online SSL checker and it is valid and installed correctly.

If you have any further questions, feel free to post them below.

Thank you,
John-Paul

You must login before you can post a comment about this answer.

Hello John Paul,

Unfortunately, you have referred me to screenshot of a WP admin panel on a site hosted by WordPress.com. My web site is built on WordPress from the WP.org repository. The feature you refer me to 'enable https' is unavailable on the profile page of a WP.org site. My current setup of WordPress does not allow me to activate https from the admin panel. Something is happening when I attempt to login to the Infinite WP dashboard. I'm getting redirected from the IWP login page on IMH's secure server to my domain url (http:spiralwebdb.com/iwp/. Not sure why.

Well, we figured out one thing....my shared SSL certificate from IMH is valid.

This issue is not resolved. I'm going to write to Infinite WP and open a new support ticket to see if the problem orginates from their end (something wonky with their code).
schnickelfritz
23 Points
2014-10-30 5:43 pm EST
Hello schnickelfritz

Thanks for letting me know, I updated the link to the wordpress.org version of the guide.

Since you are using Infinite WP, the setup is a little different. I looked on their official support site and found their guide on How to enable SSL for the admin panel.

If you are being redirected to spiralwebdb.com/iwp/ it must still be set somewhere. If you have already updated the URL in the admin section and it is still not working, you have to make the change elsewhere, such as the wpconfig file, or database. They are covered in our guide on changing your site URL.

Let us know if you get a response from the developer.

Thank you,
John-Paul
John-Paul
30,497 Points
Staff
2014-10-30 6:13 pm EST
JP: In your comment below, you refer to InfiniteWP's instructions to enable HTTPS in their config.php. The files for Infinite WP are placed in a subdirectory of one's root directory. The program connects to a separate MySQL database via settings in the IWP config.php file. HTTPS permissions can be activated in the IWP config.php file by adding an additional line of code and setting the definition to true (which I did). The addition of that code did not make a difference in my case. I still continue to receive the error message 'SSL Certificate Error'.

Not sure how changing my site url in the WordPress admin panel will help in this situation. I can login into my web domain (spiralwebdb.com) , and access it directly in a browser. My problem is logging into the admin panel of IWP, whose files are sitting in a subdirectory of my domain. I don't think changing the URL settings in my WP install is going to fix that (but I could be wrong).
schnickelfritz
23 Points
2014-10-30 6:59 pm EST
My use of the term 'SSL Certificate Error' in my last post was incorrect. I should have said 'SSL Connection Error'.
schnickelfritz
23 Points
2014-10-30 7:02 pm EST
Hello again schnickelfritz,

Since it is going to take a while to test and troubleshoot this specific issue. Please allow some time, and I will post updates as soon as possible.

Thank you,
John-Paul
John-Paul
30,497 Points
Staff
2014-10-30 8:45 pm EST
Hello J-P: Three business days have passed since you last posted regarding this issue. Has this issue risen to the top of the queue with technical support? Is IMH any closer to a resolution of the problem?
schnickelfritz
23 Points
2014-11-04 10:15 pm EST
Hello schnickelfritz,

Thank you for contacting us. I spent quite some time researching/working on this, and was unable to find a working solution. The problem is that you just want the shared SSL for the Admin section, which presents problems. You either have to change your entire site to the shared SSL, or purchase an SSL for your specific domain. Keep in mind you are not required to purchase the SSL from us.

This doesn't seem related to Infinite WP, since I am still unable to use the shared SSL for only
This is just our public forum, so there is no ticket queue. Here is our guide on how you can submit a ticket with Live Support.

If you have any further questions, feel free to post them below.

Thank you,
John-Paul
John-Paul
30,497 Points
Staff
2014-11-05 10:06 am EST
Since I was unable to resolve this problem via the community forum, I submitted a help request to tech support. They were as stumped as JP, and suggested purchasing a domain specific SSL certificate. At $125 USD a pop, I was not inclined to do that. I changed course, and successfully installed InfiniteWP on my localhost (my own computer) using an AMPPS stack (Apache server, MySQL database, Python/PHP server stack) from AMPPS Softalicious.
schnickelfritz
23 Points
2014-11-08 12:22 am EST
1

tonytran
2016-06-05 1:48 pm EST
I have faced this issue some times before. In fact, sometimes, it's not a fault from the server. I realized the ERR_SSL_PROTOCOL_ERROR appears on my Google Chrome because something just happened on my computer. I found a guide from Google to tell me disable QUIC and it helped.

https://usefulpcguide.com/16820/fix-err_ssl_protocol_error-google-chrome/

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Our Login page has moved, Click the button below to be taken to the login page.

Social Media Login

   
Social Login Joomla

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!