InMotion Hosting Support Center

Error when Connecting to PayPal

Category: Ssl

InMotionFans
n/a Points
Asked:
2016-02-26 9:47 pm EST

Hits: 149
Within the last few weeks, when using CURL to connect to PayPal, CURL reports error 35, SSL Connect Error. This error did not occur earlier, even though the PHP code I'm using has not changed. PayPal says it has recently required TLS 1.2 for secure connections and that this error may be caused by outdated SSL software on the server. Some forums say it may be caused by an outdated libcurl. My server reports version 7.19.7, while the forums say a newer version may be needed to avoid this problem. What do you think the cause may be?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

scott
Staff
43,761 Points
2016-02-29 10:01 am EST
Hello,

Sorry to hear you are having an error when connecting to PayPal. While I cannot locate the specific version needed in my search, it seems that you may need a cURL version upgrade in order for your connection to work with the PayPal.

If your server has a version of 7.19.7 and needs a newer curl version, that is not something that can be changed at the account level on a shared servers. To have a higher cURL version, you would need to upgrade to a VPS or Dedicated plan.

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!