InMotion Hosting Support Center

Updating Products in Prestashop 1.6

Category: Prestashop 15

nwcnwc28
Asked:
2015-06-06 7:17 pm EST

Hits: 2,164
At approximately 9pm EST on June 5th, when updating products in my database via Prestashop, I began to experience issues with the products updating with the changes that I had made. When I clicked on "Save and Stay", it would just take me back to my product catalog. There have been no modules added and since this started to occur, I have disabled all of the existing modules so that they could be ruled out. Prior to 9pm, I had no ocurrences of this happening. I have googled this issue and there have been many suggestions that indicate that it is module related, however after disabling all of the modules, I tried updating a product again and it would not updating still take me back to the product catalog and my updates would not take.

In testing, I have created a new product and saved it and it worked. I edited it and clicked on "Save and Stay" and did NOT experience the same issue as I was experiencing with products that were already in my catalog prior to 9pm on Friday. I even tried deleting the new product and it worked as well. Does anyone have any ideas of what might be going on? I did contact Inmotion Support and had them reboot sever functions on the server side. They even tried there own testing using another existing product that I hadnt touched and they experienced the same results.

HELP!!

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Since there was no category except for Prestashop 15, I wanted to add that I am currently using PrestaShop version 1.6.0.14
nwcnwc28
14 Points
2015-06-06 07:45 pm EST
Please help is needed in this question. thesame thing is happening to me too. have applied the possible solution listed but still not working.
trice
0 Points
2016-10-31 10:17 am EST

OTHER ANSWERS

0

scott
Staff
43,761 Points
2015-06-08 10:39 am EST
Hello nwcnwc28,

Thank you for your question on PrestaShop. Sorry to hear you are having issues with saving and editing on a product. Have you enabled caching in the store? This can sometimes cause issues like this. You can disable it to see how it behaves with it off. To do so, go to Advanced Parameters >> Performance. From there toggle the "Use Cache" switch to off.

Also, you may want to enable error reporting to see if it is also giving some sort of error when this occurs. Of so, please let us know what that error is.

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Scott,

Prior to posting the initial thread, I in fact did just as you suggested already with the enabling and disabling of the cache (both SMARTY and regular) and nothing seem to make a change. Through some more testing I have found something a bit bizarre to my situation. Some of the existing products seem to update just fine while others do not. As I said before, I have no issue with adding new products and editing them as well. Could it be that something may have gone bad in the product SQL database? Thoughts?
nwcnwc28
14 Points
2015-06-09 8:09 pm EST
0

TJEdens
Staff
10,077 Points
2015-06-10 10:08 am EST
Hello Nwcnwc28,

Have you tried removing/disabling all modules to see if the issue persist? It is possible that your database became corrupted, you can repair the database within your cPanel by going to MySQL Databases -> select the database -> click the repair button.

Best Regards,
TJ Edens

You must login before you can post a comment about this answer.

All modules were disabled and yes, the issue did persist. I will try the database repair. This option makes sense given that some products can be edited with no issue and some can not be. Thanks TJ!
nwcnwc28
14 Points
2015-06-10 11:15 am EST
Am getting the following message when I click on the repair button:

"The storage engine for the table doesn't support repair"

This is on each table within the database.
nwcnwc28
14 Points
2015-06-10 11:37 am EST
Hello Nwcnwc28,

Sorry for the continued problem with your products. First, if the repair is not working, then make sure to enable PrestaShop's error reporting. If there's a problem, then hopefully, it will show with the error reporting on. Also, you may want to experiment with the data by installing a test site and then exporting your product data and importing into the test site to see if the if it is behaving properly within a newly installed database. If the products are updating properly there, then the issue may be within the program. If not, then there may be something going on with the database. This typically as much as we can do in troubleshooting this issue. Beyond that, you may want to post in the PrestaShop forums to see if the issue has been reported or reproduced.

Kindest regards,
Arnel C.
Arn
42,973 Points
Staff
2015-06-11 3:54 am EST
Like this Question?

Related Articles

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!