InMotion Hosting Support Center

PS 1.6 Friendly URL error on Product Pages

Category: Prestashop 15

Chris_L
Asked:
2014-09-13 7:46 pm EST

Hits: 8,820
PrestaShop1.6.0.9, default theme is in use
Problem: When Friendly URL is enabled under Preferences/SEO/URL and Preferences/Product modules, the Product pages comes up with error 404 "THIS PAGE IS NOT AVAILABLE
WE'RE SORRY, BUT THE WEB ADDRESS YOU'VE ENTERED IS NO LONGER AVAILABLE".
Friendly url of other pages e.g. the CMS pages work fine though. Only the Product pages do not display.
When Friendly URL is disabled, all the pages including the product pages work/display properly.
Background information: Multi-store view is disabled, Default language is English and no other language is enabled.
I've run error reporting but nothing new comes up. The same error 404 "THIS PAGE IS NOT AVAILABLE
WE'RE SORRY, BUT THE WEB ADDRESS YOU'VE ENTERED IS NO LONGER AVAILABLE" appears on Product pages.
Any solution?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

ChristianMcQuilkin
2014-09-14 12:22 am EST
Have you tried generating the .htaccess in the generator section?
If it has been generated but the problem persists then there will need to be some edits to it as there are some factors affecting it.

You must login before you can post a comment about this answer.

Thanks for your input. Where is the 'generator' section in PS 1.6.0.9?
Chris_L
83 Points
2014-09-16 2:05 am EST
0

scott
Staff
43,761 Points
2014-09-15 7:14 am EST
Hello Chris_L,

In addition to Christian's question below, is this an upgraded PrestaShop or a new installation? Have you activated any other modules in addition to the ones activated by default?

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Hi Scott, It is a newly installed PS 1.6.0.9. I've updated some of the modules since installation in August. Yes, I think I have enabled some of the modules other than those enabled by default but I have also disabled some of them since.
Chris_L
83 Points
2014-09-16 2:11 am EST
Since I've posted this issue, I've set up a Test Store using a copy of my Live Store's database. When I enabled the Friendly URL on the Test Store and run the Error Reporting on cPanel, I got Error 403 Error 403 - Forbidden "You don't have permission to access the requested resource. Please contact the web site owner for further assistance" (On the product pages). However, only 2 of the 3 product pages have the Error 403. One of the product pages displays properly i.e. no error. I have disabled Apache's mod_security module in this test. Please advise.
Chris_L
83 Points
2014-09-16 2:21 am EST
Sorry for the late reply currently fixing my laptop, but can you check in ur .htaccess that AllowOverride is set to: AllowOverride All

If it's not in there.... Add it.
ChristianMcQuilkin
70 Points
2014-09-16 3:22 am EST
Oh and clear the cache in performance. One or the other (or both) should work.
ChristianMcQuilkin
70 Points
2014-09-16 3:26 am EST
Hi Christian, Thank you for your answers. I've checked the .htaccess and there is no 'AllowOverride'. Which line on the .htaccess should I add in "AllowOverride All"?
Chris_L
83 Points
2014-09-16 10:15 pm EST
Can you make a support ticket and ask the support team if AllowOverride is set to All. I cant check becuase well.... im not a support team member.

I ask to make this ticket, becuae ive had some experience with some hosts not having it there, just to make sure, make a ticket.

Im assuming you are using a sbared server, but ask the support team either way.
ChristianMcQuilkin
70 Points
2014-09-16 10:24 pm EST
Hello Chris_L,

AllowOverride is a viable solution and you can set that at the top of your .htaccess file. Please let us know if that helps the matter.

Kindest Regards,
Scott M
scott
43,761 Points
Staff
2014-09-17 7:20 am EST
Thank you for all the inputs. After I key in AllowOverride to htaccess file, I can't log into PS1.6 admin, it generates an 'Error 500 Internal Server Error'. I remove AllowOverride and it goes back to before. Two of the Product Pages Friendly URL still don't work (one of the Product Pages still works). I've submitted tickets to Support team many times to no avail/new suggestion.
Chris_L
83 Points
2014-09-18 12:48 am EST
Ok, I somehow got the friendly URLs to work by simply changing the 'name' of the category in PS1.6 back office, Catalog/Categories. Now the Friendly URL works for all three products. Very trivial!
Chris_L
83 Points
2014-09-18 1:05 am EST
Hello Chris_L,

We're glad you were able to get your Friendly URL's working in Prestashop. Thank you for sharing your solution.

If you have any further questions, feel free to post them below.

Thank you,
John-Paul
John-Paul
31,633 Points
Staff
2014-09-18 8:38 am EST
Why is presta shop trivial..... i think you got to 500 internal server error becuase you didnt add the directory tag. That was my bad, but glad you sorted it out.
ChristianMcQuilkin
70 Points
2014-09-18 8:58 am EST
Prestashop shows 404 on all pages instead of home page:
http://www.onstreet.ro/ceasuri-barbatesti.html?categories=

I am using Clean URLs v0.42

Can you please help me to figure it out
ziyaindia78
3 Points
2014-11-05 3:51 pm EST
Hello Ziyaindia78,

Sorry you're having problems with a plugin in PrestaShop. When I tried to find information on this plugin, I found little to no documentation on it and less support information. It does appear to be written for PrestaShop 1.5, so you should not be using it in 1.6. If you can provide a little more information on the plugin and the version of PrestaShop you're using, it would help us out. You may be better off contacting the author of the plugin for more in depth support on the issue.

Please provide more information on the plugin and we might be able to find more information in regards to troubleshooting this third-party plugin issue.

Regards,
Arnel C.

Arn
42,973 Points
Staff
2014-11-05 4:20 pm EST
Like this Question?

Related Articles

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!