InMotion Hosting Support Center

Error installing PayPal Advanced module in PrestaShop

Category: Prestashop 15

stevierayhall
Asked:
2013-09-07 2:14 pm EST

Hits: 2,015
I am trying to add the PayPal Advanced module in PrestaShop and getting an error
"Your PayPal Manager Configuration crendentials are not valid, please double-check their values or contact PayPal."

Any ideas?

Steve

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

BradM
5,399 Points
2013-09-09 10:33 am EST
Hi Steve,

I'm sorry to hear about the PayPal / PrestaShop issue that you're having, I'll see if I can help.

I haven't had to troubleshoot this problem first hand myself, so I searched online regarding the issue, and found a few posts where other users reported similar problems. The first three look like threads that you've posted?

<h2>Current Open Forum Threads - unresolved</h2>

<li><a href='http://www.prestashop.com/forums/topic/272943-trouble-logging-in/' target='_blank'>Trouble logging in</a></li>
<li><a href='http://www.prestashop.com/forums/topic/266022-paypal-usa-canada-121-not-showing-in-checkout/' target='_blank'>PayPal USA, Canada 1.2.1 not showing in checkout</a></li>
<li><a href='http://www.prestashop.com/forums/topic/273338-error-installing-paypal-advanced/' target='_blank'>Error installing PayPal Advanced</a></li>

<h2>A Forum Thread that is Resolved</h2>

I did find another post here that may have some helpful information:

<a href='http://www.prestashop.com/forums/topic/266791-problem-with-paypal-configuration/' target='_blank'>Problem with Paypal Configuration</a>

The user reported this error:
<em>Your Paypal API crendentials are not valid, please double-check their values or contact PayPal</em>

After several back and forth conversations, the user stated:
<em>I upgraded to the newest version which I successfully installed paypal...</em>

So it appears that they updated PrestaShop (or the PayPal module) to the latest version, and it apparently fixed the issue for them. I recommend doublechecking the version of PrestaShop you're using, and if it is not the latest stable version, then trying an upgrade.

Let us know if this helps or not.

Thanks,
- Brad

You must login before you can post a comment about this answer.

Brad, that user had a problem with the PayPal Api which works fine for me. Mine has to do with the section right next to that in the PayPal Module configuration for the PayPay Advanced configuration. I have the latest PrestaShop version 1.5.5 since I just installed it and the latest PayPal module 1.2.5 is already included. Having the latest version is not the problem I don't think, or maybe it is the problem. I've spent a few days now waiting for an answer to move forward. I did post the other threads, one of which had to do with the login not responding, trying a new password which was never sent and ultimately removing and reinstalling to move forward. I think there is an issue with Inmotion with Chrome or with anything where it doesn't respond leaving you thinking you're doing something wrong because nothing happens. So this is very frustrating.

stevierayhall
8 Points
2013-09-09 1:00 pm EST
Hello Steve, sorry to hear you're still having issues getting PayPal to work with Prestashop.

Are you currently attempting to use PayPal in Live or Sandbox mode? You can see some of the differences on their website in their overview of the PayPal Sandbox.

Unfortunately the error you've mentioned seems to only generate a handful of Google results, and they all seem to be sitting unresolved at the moment. More than likely in this particular case you'd be best served trying to contact PayPal, as the error itself even indicates this might be a likely solution.

It seems like you might want to possibly try to re-install the PayPal module, as it appears the test /modules/paypalusa/controllers/front/validation.php script has an error in it as well:

Fatal error: Class 'ModuleFrontController' not found in .../modules/paypalusa/controllers/front/validation.php on line 33


This error unfortunately is also very sparse in any apparent solution, so hopefully either PayPal or Prestashop will be able to step up and resolve these issues.

- Jacob
JacobIMH
9,968 Points
Staff
2013-09-09 7:04 pm EST
Fatal error: Class 'ModuleFrontController' not found in .../modules/paypalusa/controllers/front/validation.php on line 33

Re-installed PayPal and still getting this error... Please help!!
pxloft
3 Points
2015-02-22 3:22 am EST
Hello pxloft,

That error message is not something that has a specific solution as far as we've found. If re-installing it has not worked, you may want to contact PayPal and see if they have any insight.

Kindest Regards,
Scott M
scott
43,761 Points
Staff
2015-02-23 8:18 pm EST
Like this Question?

Related Articles

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!