InMotion Hosting Support Center

Opencart Export/Import Tool not in Top Admin list

Category: Opencart

Maginskyk
Asked:
2014-08-16 8:19 am EST

Hits: 190
Bulk Export/import tool is not showing up in the TOP ADMIN list for my Opencart. For ref, I did install vQmod, I did get successful install of vQmod, re-checked vQmod...said it was "already installed", checked the version number for the Opencart and I used the correct zip for Export/import , Re-copied the Export/import upload file into my Public_Html root directory for a 2nd time and still...no tool/export was listed. Any suggestion?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

update: Deleted Opencart and vqmod and reinstalled, even added the 4lines of code to the header files per the readme instructions. STILL the export/import permissions for Top Administrators will not appear? Really need assistance at this point, I'm out of ideas...called tech support, they had no suggestion but to contact opencart
Maginskyk
8 Points
2014-08-17 09:45 pm EST

OTHER ANSWERS

0

scott
Staff
28,219 Points
2014-08-18 8:41 am EST
Hello Maginskyk,

I tested the import/export tool on a fresh OpenCart installation and had no trouble getting it to display in the Top Administrator list. I will need a few more details to ensure I can set my environment as close to yours as possible.

What version of OpenCart are you using? I am using 1.5.6.4
Which specific version of the import/export module did you download? I used "opencart-1-5-4-x-export-import-13.zip"
Have you altered any file names in your setup? These need to all remain with default names.

I did find an OpenCart forum post regarding the issue as well. You may want to check and see if any of their solutions help.

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Scott, Thanks for your time. I used the files exactly as you stated. I double checked the versions and I know they are correct. I once again, this morning, started from scratch. And still no permissions showing up. I did not change any of the file names.
Just to refresh:
Opencart 1.5.6.4 is installed
Then I downloaded the zip for vQmod. I FTP'ed the folder to Public_html
I activated vQmod, got success message
Then I downloaded the zip for Export/import tool and FTP'ed files to Public_html
Per the readme file with the export tool, I had to ADD the 4 lines of code, Just a cut and paste no problems
Went to opencart dashboard and the export/import function shows up but NO permissions.
Very confused. Questions 1) Do I FTP the vQmod and export extention files to the Public_html directory or the ROOT directory, there is a listing for EACH of these in my file manager account. I put them in Public. 2) I am using SMART FTP, When I FTP the files, do I drag the top level file with the sub files in it or should drag each sub file separately. I did the top level file and they all seemed to copy. 3) Should I install the override engine? 4) If I install the engine, can I just re-FTP the export tool files or do I need to delete the old ones first.....Please assist. Keith
Maginskyk
8 Points
2014-08-19 11:36 am EST
Hello Maginskyk,

I did not have to replace any code when working with my installation. Our OpenCart and zip versions are the same, and it worked correctly when simply running the install. I'm happy to answer your questions however.

1) Do I FTP the vQmod and export extention files to the Public_html directory or the ROOT directory, there is a listing for EACH of these in my file manager account. I put them in Public.
- You want to put them in the root folder for your OpenCart. If you are using opencart as your site, then it would simply be the public_html folder. If you had OpenCart in a subfolder, say /store, then you would upload to the public_html/store folder.

2) I am using SMART FTP, When I FTP the files, do I drag the top level file with the sub files in it or should drag each sub file separately. I did the top level file and they all seemed to copy.
- I opened the top level folder and then dragged each individual folder over.

3) Should I install the override engine?
- I did not have to do so.

4) If I install the engine, can I just re-FTP the export tool files or do I need to delete the old ones first?
- You can re-FTP, just make sure it is overwriting the ones that are already present.

Not being able to duplicate it on our side makes it hard to give any actionable advice. I hope some of this helps. One final question, have you tried to do a fresh install to a subfolder,then install the vqmod and then the export/import to see if it works? If so, this may indicate some other configuration, plugin, etc that could be interfering.

Kindest Regards,
Scott M
scott
28,219 Points
Staff
2014-08-19 1:20 pm EST
0

JohanH
2014-08-27 3:39 pm EST
Hi !
I had the same challenge as you - did copy the upload folder etc - but I did have to manually copy the admin and system directories as well. Then everything worked as it was supposed to and I could select the user rights....

Best,
Johan

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Social Media Login

   
Social Login Joomla

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!