InMotion Hosting Support Center

Why isn't SpamAssassin's rewrite_header Subject working?

Category: Fighting Spam

2012-11-13 10:37 pm EST

Hits: 1,151
Hello, I enabled SpamAssassin and I want to filter Spam using the "rewrite_header Subject" tag but it's not working.

I followed the steps outlined in the cPanel Interface Help.

I'll post it below for anyone that isn't familiar with it.


Sorting spam with your email client

This is the preferred method of sorting and deleting spam messages. With SpamBox disabled, you can configure SpamAssassin to mark your email with an identifying subject (such as +++SPAM+++), which can then be used to filter each message into an appropriate location.

To do this, you must directly edit the SpamAssassin configuration file on the server, if your web host allows this. Its location is: /home/example/.spamassassin/user_prefs (where “example” stands for your cPanel username). Within this file, you must add a line formatted like this:

rewrite_header Subject +++SPAM(SCORE)+++

This will cause the subject line of a message marked as spam with a score of 6 to begin with +++SPAM(6)+++

You can then use cPanel’s Account Level Filtering feature to reroute messages based on their spam scores, as you desire.

You must login before you can ask a follow up question.

You must login before you can submit an answer.



5,889 Points
2012-11-14 10:12 am EST
Thank you for your question Nelson!

Sorry for the trouble with the spam assassin headers not working. Our systems support will need to look at the spam assassin configuration. Unfortunately, this type of request cannot be done through the support center forum. Our tech support staff will need to do this. Please contact support by email ( with this request. You will need to verify the account with the original AMP password or the last 4 digits of the credit card on file in the email. They will need account information like the domain on the account or the cpanel username. Also, please include the exact steps to replicate the problem. Please include any login credentials and/or links we will need to replicate the problem. Thank you for your patience. Sorry for the inconvenience.

Take Care!

James R

You must login before you can post a comment about this answer.


5,889 Points
2012-11-14 10:19 am EST
P.S to my last comment.

I was able to get with systems on this and they disabled global subject rewrite and enabled it and then re-enabled it through the WHM. Please see if the subjects are writing correctly now.

James R

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Our Login page has moved, Click the button below to be taken to the login page.

Need more Help?


Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!