InMotion Hosting Support Center

Drupal website view cannot be edited

Category: Drupal 7

InMotionFans
n/a Points
Asked:
2015-07-25 9:35 pm EST

Hits: 125
On a Drupal 7 website (one.sohistory.org) I have multiple views that work, but several views hang up during editing and produce AJAX HTTP errors (sometimes Error 200, sometimes 500). After reading multiple responses to related problems I have disabled the views slideshow modules, but that made no difference. I don't have jquery update loaded. Apparently some versions of that cause problems, but I wonder if I need to load it.
I couldn't find the right file for increasing the max_allowed_packet, another suggested fix.
The view involves a content type (Photos Database) that has about 60,000 entries, but I have other views that use this content type and don't produce the same errors.
Each time I try to use the view the system is doing something for several minutes before I get an error message, so I'm concerned it's creating heavy use on the website-hate to keep spinning that wheel...

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

1

scott
Staff
43,761 Points
2015-07-27 8:17 am EST
Hello,

Sorry to hear you are having trouble with your Drupal site views. I have not personally seen this error before so I do not have any first hand experience in fixing it. I would definitely try setting the max_allowed_packet setting if you have not yet done so. This can be set in the php.ini file. Give that a try and if not, please let us know. Have you found a specific number of entries where the error occurs? You say the view involves 60,000 entries, but does it work with 10,000, 20,000, 30,000, etc? Is there a specific number where it seems to give up and give the error? Does this occur in an offsite test environment?

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Thank you. I must be missing something obvious. My php.ini file doesn't include a max_allowed_packet setting, and the phpinfo.php file doesn't show it.
patoregon
15 Points
2015-07-27 11:20 am EST
I'm sorry, I didn't answer the question you asked. I've created other views using the same database, and I have another database that also has at least 60,000 records (Mega Index), but it works well with views. I have had occasional AJAX errors, but the worst one seems to be related to one specific field. It's just a location field that has entries such as G35 A 3.
patoregon
15 Points
2015-07-27 11:23 am EST
Hello patoregon,

I misspoke earlier when I advised to set in the php.ini file. You can set that in the my.cnf file for MySQL. Unfortunatley, that file cannot be altered on a shared server. That would take a VPS or a Dedicated server plan. I am not sure what extra help I can provide as I would need to set up a test environment with duplicate data to begin troubleshooting and altering settings. Have you tried the Drupal forums to see if they have come across this issue?

Kindest Regards,
Scott M
scott
43,761 Points
Staff
2015-07-27 3:31 pm EST
Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!