InMotion Hosting Support Center

Drupal permisssion issues

Category: Drupal 7

2013-09-12 9:28 am EST

Hits: 871
On my website I am getting the following in the error log.

[Thu Sep 12 06:08:51 2013] [crit] [client] (13)Permission denied: /home/compu120/public_html/sites/default/files/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:

I changed the permission to .htaccess to 777 just to see if I could get it to work, but no dice.

Also, I cannot see photos stored under my sites directory. You can see on the home page that a X is displayed instead of the photo. I suspect it is a file permission or file ownership issue.

Can anyone give me a hint on how to get rid of that message from the error log and how to get photos to render.

You must login before you can ask a follow up question.

You must login before you can submit an answer.



11,186 Points
2013-09-12 2:08 pm EST
From taking a look at both your site and the error message you provided, it does look like you have some permissions issues. For example, one of the images that is loading on your home page has the following file path:

It looks like you just need to take a look through your files, change the permissions, and you will be all set. This article will help you out with looking over your file permissions and making the necessary changes:

Changing File Permissions

You must login before you can post a comment about this answer.

i just updated it to 777 and it still will not display. I am pretty sure having [Thu Sep 12 11:17:57 2013] [crit] [client] (13)Permission denied: /home/compu120/public_html/sites/default/files/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: is not a good thing. I copied this website from one that is working fine in a VM. Only difference I can think of is that the owner of the files is different. I cant really tell who owns them with the file browser.
14 Points
2013-09-12 2:24 pm EST
I even made /home/compu120/public_html/sites/default/files/.htaccess 777 and it still get that permission denied error.
14 Points
2013-09-12 2:47 pm EST
Solved. I had to make sites/default/file 777. I supposes because my user ID owns all files in the website, as opposed to the apache user on my test website.
14 Points
2013-09-12 3:48 pm EST
Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!