InMotion Hosting Support Center

My site will not load if I add "www." to the domain :(

Category: Domain Names

Bamphalas
Asked:
2015-03-16 1:17 am EST

Hits: 178
I get a 500 Server Error if I include the "www." in my domain. If I omit it, the site loads up. I checked to make sure my domain was configured to correctly see the inmotion name servers. Was there something special I needed to do when I did "add domain"? What could be causing this?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Please note that this is not my main domain. That works perfectly fine. It an added domain pointing to another prestashop install.
Bamphalas
8 Points
2015-03-16 01:19 am EST

OTHER ANSWERS

0

scott
Staff
43,761 Points
2015-03-16 5:19 pm EST
Hello Bamphalas,

The www subdomain should point to the main domain as a CNAME. You can check that via the Advanced DNS Zone Editor within the cPanel.

I did check the addon domain you referenced and it was working fine. Were you able to correct it yourself or are you still seeing the issue?

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Thanks Scott. I was able to correct it myself. Today both versions of the name stopped working. I could directly access files in the folders, but accessing my shop's front end was impossible (the back end suddenly started to work). Found some information linking 500 errors to permission so I checked folder permissions in cpanel and found a ton that did not have the recommended values. So many that I had to look for alternative solutions. Found a youtube tutorial that suggested going into the "defines.inc.php" file in the subdirectory's config folder and turn on the developer debug mode in there. Once I did that, the 500 error screen vanished and it revealed to me that for some reason Prestashop's theme was no longer selected. I went into the back end (that was mysteriously working) and activated a theme on my Prestashop and boom it worked. So far it has been working today with no more issues.
Bamphalas
8 Points
2015-03-17 12:25 am EST
Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!