Perl modules are not seen

Category: Cpanel

gstahl
Asked:
2014-08-15 7:08 am EST

Hits: 85
I've installed several Perl modules on my dedicated server that are needed for my YaBB 2.6 forum. The program sees some of the modules, but not some of the others. I've reinstalled them and still no luck. In particular, DateTime::TimeZone is not seen. This is affecting the clock for the many time zones that our group encompasses.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Additional Perl modules that are installed but not 'seen' by the program are as follows: Crypt::SSLeay; Compress::Bzip2; Net::SMTP::TLS;
gstahl
11 Points
2014-08-15 07:44 am EST
The information that I get back from my Perl Module check program is as follows: Can't locate DateTime/TimeZone.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . ./Modules)

Can't locate Net/SMTP/TLS.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . ./Modules)

Can't locate Compress/Bzip2.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . ./Modules)
gstahl
11 Points
2014-08-15 07:46 am EST

OTHER ANSWERS

0

Scott
Staff
24,272 Points
2014-08-15 8:25 am EST
Hello Gstahl,

The Perl modules should be available if they have been installed correctly. If you are certain they have been and are still not seeing them, this may have to do with a server configuration or other mismatch. In that case, you will want to contact our Live Support team so they can check your particular setup.

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

I put in a ticket and a description of the issue via my AMP.
gstahl
11 Points
2014-08-15 8:29 am EST
I should also add that several other modules that I added are 'seen' by the software, it is just these several that are not 'seen'. I'm sure there is a server configuration issue most likely, since some of them work and others don't
gstahl
11 Points
2014-08-15 8:31 am EST
Like this Question?

Support Center Login


Social Media Login

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!