InMotion Hosting Support Center

Not getting correct address on using redirect

Category: Cpanel

InMotionFans
n/a Points
Asked:
2015-05-01 7:48 pm EST

Hits: 56
I've done a general redirect of one site (americanlegionpalmsprings.org) to another (palmspringslegion.org) and the redirect works for the index pages. However, I'm not having much luck with any of the specific pages -- i.e., if I do a redirect of http://www.americanlegionpalmsprings.org/index.php?id=99 to http://palmspringslegion.org/at-the-post/rent-our-hall, what comes when I try it out on the web (by clicking on is a 404 error and the URL of http://palmspringslegion.org/at-the-post/rent-our-hall?id=99. Is there any way for me to get rid of that ?id=99?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

John-Paul
Staff
31,633 Points
2015-05-01 8:16 pm EST
Hello,

Thank you for contacting us about an incorrect address when redirecting. When I tested the above address, it is not redirecting for me at this time. We are happy to help troubleshoot the issue, but we will need some additional information.

How did you setup the redirect? For example, are you custom-coding it in the .htaccess file, or are you using the Redirects tool in cPanel?

If you are custom coding a solution, please provide the syntax you are using. This will help us narrow down the cause of the redirect issues.

If you have any further questions, feel free to post them below.

Thank you,
John-Paul B

You must login before you can post a comment about this answer.

I am using the redirects tool. The line that the tool placed for the redirect is:
RewriteRule ^99$ "http\:\/\/palmspringslegion\.org\/at\-the\-post\/rent\-our\-hall" [R=301,L]
psemerson
3 Points
2015-05-01 11:23 pm EST
Hello psemerson,

These can be a funky, try adding a ? at the end of the URL portion of the rewrite rule:

RewriteRule ^99$ "http\:\/\/palmspringslegion\.org\/at\-the\-post\/rent\-our\-hall?" [R=301,L]

I believe that should remove the parameter at the end of the URL.


Kindest Regards,
Scott M
scott
43,761 Points
Staff
2015-05-03 8:32 am EST
Like this Question?

Forum Login

You are NOT logged in. You can still browse our Support Center.

To participate within our Community Support Forum:

Need more Help?

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!