InMotion Hosting Support Center

"Moodle 2.1 or later requires at least PHP 5.3.2

Category: Cpanel

2013-02-23 1:56 pm EST

Hits: 747
I keep getting a cron error regarding my moodle 2.4 installation even though I update the PHP version via c-panel. I get an email every hour since I installed moodle.

The subject line reads " /usr/local/cpanel/3rdparty/bin/php -q /home/n*****12/public_html/moodle/admin/cli/cron.php

The actual error reads "Moodle 2.1 or later requires at least PHP 5.3.2 (currently using version 5.2.6). Some servers may have multiple PHP versions installed, are you using the correct executable?"

I need help.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Best answer chosen by User


43,761 Points
2013-02-25 10:50 am EST
Hello Sid12,

When you set the php version in the cpanel, this does not apply to the crons. The cron will use the default php for the server, which is the 5.2.6.

You can, however, have the Cron use the newer php, you simply have to change the way it is calling the php.

For your situation, change
/usr/local/cpanel/3rdparty/php -q

/opt/php54/bin/php -q -c

This allows the cron to call the php switch that will run the moodle.

You will want to do that for both crons and they should then run fine.

Best Regards,
Scott M

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Our Login page has moved, Click the button below to be taken to the login page.

Social Media Login

Social Login Joomla

Need more Help?


Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!