InMotion Hosting Support Center

Users of Moodle 2.1 and higher versions may experience an issue when attempting to install Moodle (using Fantastico or manually). Users who install Moodle through Fantastico are able to complete the installation but will see a blank white screen when attempting to log in. Users who attempt to install Moodle manually, will receive an error that Moodle requires PHP version 5.3.2.

This is due to a mismatch in the required PHP version for Moodle 2.1 and higher. Currently, PHP 5.3 is not available on our servers. Unfortunately, upgrading to PHP 5.3 in a shared environment is not an option. This can potentially break other customers software they might be using to operate their websites. 

To use Moodle 2.1 please see our article:

Modifying the lib.php file in Moodle 2.1 versions and higher

Before making and changes, we do recommend creating a backup of your account. If you have any further questions please feel free to submit a question in your Community Support area

Continued Education in Course 300: Advanced Tutorials
You are viewing Section 7: Moodle Requires PHP 5.3.2 - Work Around
Section 6: How to install Moodle using Fantastico
Section 8: Editing the lib.php file in Moodle

Post a Comment

Name:
Email Address:
Phone Number:
Comment:
Submit

Please note: Your name and comment will be displayed, but we will not show your email address.

0 Questions & Comments

Post a comment

Back to first comment | top

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!