Wordpress Jetpack plugin stopped working

Category: Wordpress

aplatac
Asked:
2012-04-06 9:17 am EST

Hits: 1,280
I've used the Wordpress Jetpack plugin for months without problem. The stats stopped working a few days ago.

I uninstalled and reinstalled the plugin. When I try to complete the installation by contacting Wordpress, I get the following error:

"Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.

SSL connection timeout"

Wordpress support suggests this is caused by something incorrectly configured on the host. I do not recall making any changes in cPanel prior to this happening.

Anyone encountered similar problem? Has inMotion made any changes recently that might cause this error?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

BradM
Staff
5,399 Points
2012-04-06 9:43 am EST
Hi aplatac,

I did some research on this error message for you, and first wanted to share some great topics I found:

register_http_request_failed ... SSL connection timeout

[resolved] [Plugin: Jetpack by WordPress.com] Your Jetpack has a glitch, This usually means your site is not pu (27 posts)

It is interesting to see that users were reporting similar errors as yourself, and there were all on different hosting providers. Then all of a sudden, it seems that WordPress changed something because you can see everyone chime back in again stating that their issue was resolved.

I also found this page:
New update: Jetpack 1.1.2

.. and on that page it mentions:

Fixes for many “register_http_request_failed” errors caused by hosts making https requests, without verifying SSL certificates.

That page is almost 1 year old now, but what I would suggest is checking to see if there is by chance a newer version of the Jetpack plugin you can install, which may help correct this issue.

Has inMotion made any changes recently that might cause this error?

As far as I'm aware, we have not made any changes recently that would cause this problem.

I hope this helps point you in the right direction! Feel free to post a comment at the bottom of this page if we can help further.

Thanks,
- Brad

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!