InMotion Hosting Support Center

Website down -error message -help!

Category: Wordpress

theartsandcraftsplace
Asked:
2013-05-03 12:47 pm EST

Hits: 460
I am getting this error message:

RewriteCond: bad argument line '%{R'

How do I fix this? I am using Wordpress.

Thanks!

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

JacobIMH
9,968 Points
2013-05-03 1:02 pm EST
Hello theartsandcraftsplace, and thank you for your question.

I've gone ahead and resolved this error for you. For future reference, you can use our guide on <a href="http://www.inmotionhosting.com/support/website/general-server-setup/where-is-my-htaccess-file" target="_blank">where is my .htaccess file located</a> to take a look at your <strong>.htaccess</strong> file which had the broken <strong>RewriteCond</strong> in it. It looks almost as if the default WordPress rewrite code had been duplicated, but not completely.

This is what you had before I made changes, with the problem highlighted in <strong style="color: red;">red</strong>:

<p class="code_block" style="width: 350px; line-height: .8em; overflow: hidden;"># BEGIN WordPress<br />
&lt;IfModule mod_rewrite.c&gt;<br />
RewriteEngine On<br />
RewriteBase /<br />
RewriteRule ^index\.php$ - [L]<br />
<strong style="color: red;">RewriteCond %{R</strong><br />
# BEGIN WordPress<br />
&lt;IfModule mod_rewrite.c&gt;<br />
RewriteEngine On<br />
RewriteBase /<br />
RewriteRule ^index\.php$ - [L]<br />
RewriteCond %{REQUEST_FILENAME} !-f<br />
RewriteCond %{REQUEST_FILENAME} !-d<br />
RewriteRule . /index.php [L]<br />
&lt;/IfModule&gt;<br /><br />

# END WordPress</p>
This is what is left now:

<p class="code_block" style="width: 350px; line-height: .8em; overflow: hidden;">
# BEGIN WordPress<br />
&lt;IfModule mod_rewrite.c&gt;<br />
RewriteEngine On<br />
RewriteBase /<br />
RewriteRule ^index\.php$ - [L]<br />
RewriteCond %{REQUEST_FILENAME} !-f<br />
RewriteCond %{REQUEST_FILENAME} !-d<br />
RewriteRule . /index.php [L]<br />
&lt;/IfModule&gt;<br /><br />

# END WordPress</p>
I went ahead and tested the site and it looks like it should be working again now. If you're still having any issues at all, or have any further questions, please feel free to let us know!

- Jacob

You must login before you can post a comment about this answer.

Like this Question?

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!