Problems moving wordpress site to InMotion

Category: Wordpress

citygirlfarming
Asked:
2013-06-28 3:18 pm EST

Hits: 1,232
I've watched (and followed) the video that walks me through moving my wordpress blog over to InMotion (as an /blog extension to a site I already have up there), and when I get to the very last step of uploading files and importing to my new location, I get a long line of error messages that say FAILED TO IMPORT___ and it lists my entire site. I've tried over and over, carefully following the directions and can't seem to make it work. HELP??? Please. :)

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

johnpaulb-imhs1
Staff
9,684 Points
2013-06-28 4:49 pm EST
Hello citygirlfarming,

Thank you for your question. It's possible the size or amount of files may be taking a long time, causing you to hit a PHP limitation. Putting Wordpress in debugging mode may help provide a more detailed error.

For example:
upload_max_filesize = 256M

This means that 256 MB is the largest file you can upload.

Here is another example:
max_execution_time = 130

This sets how long a script can run (in seconds), in this example it is set to 130 seconds.

You can change (increase) these PHP settings for your entire account by modifying the php.ini file within your public_html folder, then making the file recursive(makes it affect all files/folders).

If you have any further questions, feel free to post them below.
Thank you,

-John-Paul

You must login before you can post a comment about this answer.

I changed the information in the php.ini file, but when I go into the .htaccess file and add the in information to make it recursive, I save the information, but it's not saving for some reason? I'm opening it in notepad if that makes a difference? Sorry for the hassle. I really appreciate your help.
citygirlfarming
16 Points
2013-06-28 6:25 pm EST
Hello Citygirlfarming,

Thanks for the question -it's no hassle! When you open a file in notepad, you're basically opening a file on your computer. The file is not going be saved on the hosting server. If you're going to use Notepad, you would need to save the file as a ".htaccess", then upload it overwriting the existing file in your public_html folder.

If you want simpler, use the Cpanel File manager and code editor in order to edit your file. Using the code editor, the lines are numbered and you are editing and saving the file directly on the server.

That way when you save your changes, they're immediately on the server. Try this first, and if you're still having problems please let us know.

Regards,
Arnel C.
Arn
17,354 Points
Staff
2013-06-28 6:33 pm EST
Okay I got the code changed in the .htaccess page, but I'm still getting the long list of "failed to import post tag" and a huge long list of all my blog posts, which say, "Failed to import "title of post" invalid post type". ???
citygirlfarming
16 Points
2013-06-28 8:11 pm EST
Hello Citygirlfarming, sorry to hear you're still having some issues importing your WordPress.com website into your account.

I unfortunately was unable to find a /blog directory on your account, or any WordPress .xml files to use for the import.

Typically when you're running into a Failed to import or Invalid post type error, this can be caused by corruption in your backup file. So you might want to try to export it again from WordPress.com.

Another common problem I've seen is that sometimes the .xml file is too large for the server to process. If this is the case, you can try following these steps to hopefully get things successfully imported:


  1. Download 7-Zip or another file archiver.

  2. Right-click on your WordPress exported .xml file -> 7zip >Add to Archive

  3. For the Archive format option, select gzip.

  4. Here is a small video of this in action:



  5. Try to upload the .gz file instead of your .xml one into WordPress.

  6. Depending on the size of your file, you might need to adjust these values in your php.ini file as well:

    default_socket_timeout = 600
    max_execution_time = 600
    upload_max_filesize = 256M




Please let us know if you're still encountering any issues at all.

- Jacob
JacobIMH
9,968 Points
Staff
2013-07-01 2:43 pm EST
Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!