InMotion Hosting Support Center

Php extensions in php.ini

Category: Wordpress

MichPope
Asked:
2012-05-21 11:42 pm EST

Hits: 1,072
CGI/FastCGI is not the problem, maybe below extension didn't activated that's why my php script doesn't work.
below extension configure only on Windows , how use the extension on linux ?

extension=php_bz2.dll
extension=php_curl.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_mbstring.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdo_mysql.dll
extension=php_pdo_sqlite.dll
extension=php_sqlite.dll
extension=php_sqlite3.dll
extension=php_xmlrpc.dll

thank you.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

scott
Staff
25,902 Points
2012-05-22 8:15 am EST
Hello MichPope,

As .dll extensions are Windows only, you will want to replace them with .so extensions. For example use extension=php_bz2.so in place of extension=php_bz2.dll

Do this for all of them in the php.ini file and that should enable the extensions that exist on the server.

I hope that answers your question, if you have any further questions on the issue please leave a comment below.

Thank you!
- Scott M

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Social Media Login

   
Social Login Joomla

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!