InMotion Hosting Support Center

I am getting this error on my wordpress website admin when trying to upload a product image: Fatal error: Maximum execution time of 30 seconds exceeded in /ho

Category: Wordpress

2013-01-28 11:25 am EST

Hits: 1,296

You must login before you can ask a follow up question.

You must login before you can submit an answer.



9,968 Points
2013-01-28 11:42 am EST
Hello tinyolive, and thanks for your question.

Unfortunately it looks like your question got cut off as you tried to enter everything into the subject of the question. I also couldn't find the email account associated with your account in our system to see what hosting account you're using.

It sounds like you're hitting the default 30 second maximum execution time for PHP scripts. You can alter the max_execution_time setting in your php.ini file in your /public_html/ directory to a higher value to avoid this problem. Then you'd want to make your php.ini file recursive so that those settings apply for all of your sub-directories.

If you can let us know your cPanel username than we can go ahead and make a copy of the server's default php.ini file for you and place it in your /public_html/ directory, and then you would have the ability to go in and edit your settings to match what you need.

If it's taking longer than 30 seconds to upload a product image, you might want to also consider trying to optimize the image for the web prior to uploading it via WordPress. All in all when dealing with PHP script uploads these are the settings you would want to adjust in your php.ini file to ensure you don't encounter any problems:

  • upload_max_filesize

  • max_input_time

  • memory_limit

  • max_execution_time

  • post_max_size

If you can't figure out adjusting these on your own to get things working for you, please let us know your cPanel username and like I said we can copy of the server's php.ini file for you.

- Jacob

You must login before you can post a comment about this answer.

Hello Jacob,
I'm getting the same error on my wordpress website and I didn't find the php.ini file in the public_html directory to fix it. Can you help me? My cpanel username is ******68
3 Points
2015-09-06 7:28 pm EST
Hello supersmart_Admin,

Thank you for contacting us. Since this is just our public forums, we cannot make any changes to your account from here. I also marked out your username for security purposes.

If you do not see a file named php.ini in your public_html, please contact our Live Support Department and request that we create one for you.

Thank you,

19,934 Points
2015-09-08 9:54 am EST
Like this Question?

Need more Help?


Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!