How can I increase php memory limit to 64MB?

Category: Wordpress

kaixin5
Asked:
2012-06-25 9:49 pm EST

Hits: 1,713
Hi,

My wordpress system status shows "WP Memory Limit" is 32MB, not recommended 64MB. How can I increase it?

Thanks!

You must login before you can ask a follow up question.

You must login before you can submit an answer.

I have modified the php.ini file as indicated, as well as placed appropriate code in my wp-config file to increase the memory limit. My system status is still showing that the memory limit is 40MB. What can I do to fix this? Thanks.
sonowats
0 Points
2013-10-16 12:20 pm EST
Hello Sonowats,
In that case you will also want to check to ensure you have php.ini set as recursive. You can find instructions on how to do that in the article below:|

http://www.inmotionhosting.com/support/website/php/recursive-php-ini

Kindest Regards,
Scott M
Scott
17,998 Points
2013-10-16 12:48 pm EST
Thanks Scott. I made the changes as indicated. When I run a report with a phpinfo.php file, I can see that the memory limit is indeed 96MB. However, my system status within Wordpress is still indicating it as 40MB. I'm guessing this is outside the realm of InMotion support. Thanks for your help.
sonowats
0 Points
2013-10-16 03:35 pm EST
Sonowats,

You may need to increase this within the Wordpress configuration as well. This article on the official Wordpress documentation should get you pointed in the right direction:

Increasing memory allocated to PHP

You will just need to add the lines as provided there into your w-config.php file for Wrodpress to allow a higher memory usage.
JeffMa
8,314 Points
2013-10-16 04:05 pm EST
Yep, I have that line in my config file. Very odd that it is not registering correctly on my install. Maybe it's a plugin error. Thanks for your help.
sonowats
0 Points
2013-10-16 04:14 pm EST
Hello Sonowats,

I tried to look up your account based off the email used here in this public Q&A site, and it doesn't look like either account that came up had a recent .htaccess file modification on them, or a php.ini file.

If you'd like to let us know what account you're having these issues with we'd be glad to lend you hand. You can either respond here publicly, or contact technical support for further assistance.

- Jacob
JacobIMH
9,968 Points
2013-10-16 04:19 pm EST

OTHER ANSWERS

0

Scott
Staff
17,998 Points
2012-06-26 9:00 am EST
Hello kaixin5,

Normally you can alter that from the php.ini file found in your public_html folder. The setting is named memory_limit.

I did not see a php.ini file in your account so I placed a default one there for you. The memory limit in that php.ini file is set to 512MB, so you should be all set.

I hope this answers your question. If you have any more questions or information specific to the issue please leave a comment below so we can further assist you.

Best Regards,
Scott M

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!