InMotion Hosting Support Center

Still getting a 500 internal server error


monica67
Asked:
2012-02-15 6:43 pm EST

Hits: 3,404
Hi Tim,
I wasn't able to come back here right away due to login problems. I'm back now! I'm creating a new question because the original one says it's "expired." Not sure what that means, but I'm thinking a reply won't show up.

You replied to my question about getting a 500 Internal Error when I tried to access my mobile site (thru the WordPress app) by saying you only saw a directory when you went to that URL.

I get the same result when I go straight to the mobile URL. It says "Index of /." When I click on the link (cgi-bin) it says forbidden, then "Additionally a 500 Internal Server Error was encountered..."

I had been using the WordPress mobile app to access the site and that's when I got the 500 error.

The only way I can access my site on a mobile device is by typing in the regular URL. Then I get a choice of going to the desktop site, which works, or the mobile site - and then we're back to the directory page.

I've gone thru all the settings for Wordpress's mobile switcher that comes with the software, so I don't know what else I need to do.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

CNick
1,344 Points
2012-02-15 7:27 pm EST
Hello monica67,

I'm sorry you're having trouble setting up the Mobile Pack plugin for your WordPress site. Let me first apologize that my comment on your <a href="http://www.inmotionhosting.com/support/community-support/website-troubleshooting/how-do-i-solve-a-500-internal-server-error">previous similar question</a> was incorrect. Instead of creating a redirect from the mobile subdomain to the main domain, what works correctly with this plugin is <a href="http://www.inmotionhosting.com/support/website/cpanel/how-do-i-create-a-subdomain-in-my-control-panel-cpanel">creating the subdomain</a>, but then setting the directory for that subdomain to the same directory as your main domain (public_html). I tried this out on a test installation of WordPress and it worked correctly when I created the subdomain and made sure the subdomain points to the same <a href="http://www.inmotionhosting.com/support/website/getting-started-guides/where-to-upload-files">directory as the main domain</a>. I think this has something to do with the selecting BOTH for the switcher mode. You could also try just using browser detection and you wouldn't have to create a separate subdomain for your mobile website.

Please let us know if you have any additional questions or need further assistance.

Regards,

Christi N.

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Social Media Login

   
Social Login Joomla

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!