php curl not working over https


gacktsan
Asked:
2013-08-29 6:01 pm EST

Hits: 1,762
I have a php script trying to get some data from a google server. It needs to do it over https.
It has been working fine for months and recently (maybe today) it stopped working all of a sudden.

The curl_exec() function is just exiting the script execution without reporting anything.
I've added echo lines so you could see exactly where the execution stops.
http://www.koukanstation.com/test.php

I had a similar problem with php's fopen/fread not working over a https connection, so I'm starting to think something was changed on the server to prevent https from working in php.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

I solved it. Changing the php version from 5.2 to 5.4 fixed it. (this is changed in from the account management portal page)
gacktsan
32 Points
2013-09-05 02:23 pm EST
Hello gacktsan,

Thank you for letting us know that changing your account's PHP version resolved this issue for you!

- Jacob
JacobIMH
9,968 Points
2013-09-05 02:53 pm EST

OTHER ANSWERS

0

Arn
Staff
17,716 Points
2013-08-29 8:32 pm EST
Hello Gacktsan,

Apologies for the problem with the cron job issues. I just spent about half an hour looking at your problem with a Tier2c tech. The weird thing is that were able to get the script working in shell (ssh), but NOT in a web browser. We're not sure why that would be the case. I need to ask Jacob to review the issue again tomorrow since we do not cover the support center 24 hours. We'll post information on this issue tomorrow after further investigation.

Apologies for the delay in providing a solid answer. We should have more information after further review tomorrow.

Kindest regards,
Arnel C.

You must login before you can post a comment about this answer.

0

JacobIMH
Staff
9,968 Points
2013-08-30 12:10 pm EST
Hello gacktsan,

This issue should be resolved now. It looked like the PHP SSL library was not able to load successfully on the server and this was causing the issues pulling content over a SSL connection.

Please let us know if you still are noticing any problems at all.

- Jacob

You must login before you can post a comment about this answer.

It seems to not be working still.
Maybe it was working earlier and stopped again.
The script I referenced in the first post still stops execution on curl_exec()
gacktsan
32 Points
2013-08-30 2:04 pm EST
It's been 3-4 days now and still no progress.
The script referenced in the original post isn't working.
curl_exec() on a https connection isn't working.
gacktsan
32 Points
2013-09-03 6:06 pm EST
Hello Gacktsan,

Apologies for the delay in getting you a response. The issue was initially reviewed and resolved (we thought) by one of our team members, but you have reported the problem still persists. I have gone ahead and filed a support ticket on your behalf regarding the issue. This ticket is directly assigned to our Systems team. They will need to investigate the issue for you. You should see a response from them. All responses are being sent to the owner of the hosting account and the contact information there.

Apologies for the delay and problems you have been having as a result of this issue. You should see a response from our systems team when they have investigated the issue.

Regards,
Arnel C.
Arn
17,716 Points
Staff
2013-09-04 5:07 pm EST
Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!