How do I force Facebook to re-index my site since links display the wrong thumbnail?


Flakkak
Asked:
2012-03-12 6:29 pm EST

Hits: 14,480
When I type my website URL(www.quebec-connection.com) in facebook to share it on my wall, it shows a thumbnail like this:

''Web Hosting by InMotion Hosting
http://quebec-connection.com/
If you own this site, your new web hosting account is now activated!Please make sure to replace this page with your own index.htm page.''

So I'd like to show the proper information when I share my website. It's been like this for 4-5 days(since I joined InMotion). Contacted support char 2 times and didn't solved it. I built my website with Iweb.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Hi Tim,

I was facing a big issue with my website, www.pixorange.com which was hosted with Hostgator. Currently moving to Inmotion VPS. We have an issue in which some of our website links are not able to post in Facebook, the result comes up with no image or just link. We did use the Lint tool of Facebook and received an error stating that ""Error Parsing URL: Error parsing input URL, no data was scraped."

When debug frequently on the link, we get 200 response code from it. Even after that we will not be able to post the links and results comes up with no image. The issue with some of links and it changes frequently. Here are some links for your reference:

http://pixorange.com/prevent-dry-eyes/
http://pixorange.com/anil-kapoor-finds-sunny-leone-beautiful/

We did check our FB app settings and is correct as per our developer. When I analyse the domian using DNS look up, I found that the server is blacklisted. Also our webmaster told me that the server may block the fb request.

Due to this reason, we did thought of changing our server to Inmotion hosting. Looks like the hostgator server is giving bad gateway.

Here is the domain for your reference:

www.pixorange.com

Let me know, your thoughts. We will moving the files today to Inmotion hosting, and does want to have a bad gateway from Inmotion hosting.

Thanks,

Vineeth M K
vineeth
14 Points
2013-04-07 09:42 am EST

OTHER ANSWERS

0

Tim S.
Staff
9,967 Points
2012-03-13 6:53 am EST
Hi Flakkak,

Thanks for posting your question. I'm more than happy to assist you. The issue is with how Facebook has indexed the page. Facebook is displaying the page they have indexed which happens to be the landing page. You can use the Facebook Lint Tool to help Facebook grab the correct image. Here's a link to the tool:

FaceBook Lint Tool

This will tell Facebook to re-crawl your URL, and provide any errors they may have found when crawling. Once they have re-crawled your website, the issue should be corrected.

If you need further assistance please feel free to contact us.

Thanks!

Tim S

You must login before you can post a comment about this answer.

Hi Tim,

I was facing a big issue with my website, www.pixorange.com which was hosted with Hostgator. Currently moving to Inmotion VPS. We have an issue in which some of our website links are not able to post in Facebook, the result comes up with no image or just link. We did use the Lint tool of Facebook and received an error stating that ""Error Parsing URL: Error parsing input URL, no data was scraped."

When debug frequently on the link, we get 200 response code from it. Even after that we will not be able to post the links and results comes up with no image. The issue with some of links and it changes frequently. Here are some links for your reference:

http://pixorange.com/prevent-dry-eyes/
http://pixorange.com/anil-kapoor-finds-sunny-leone-beautiful/

We did check our FB app settings and is correct as per our developer. When I analyse the domian using DNS look up, I found that the server is blacklisted. Also our webmaster told me that the server may block the fb request.

Due to this reason, we did thought of changing our server to Inmotion hosting. Looks like the hostgator server is giving bad gateway.

Here is the domain for your reference:

www.pixorange.com

Let me know, your thoughts. We will moving the files today to Inmotion hosting, and does want to have a bad gateway from Inmotion hosting.

Thanks,

Vineeth M K
vineeth
14 Points
2013-04-07 9:42 am EST
Can you help
Using the Facebook Lint Tool the web site image is correct I use the Debug butt but the posted website still shows the old image,
Do I have to wait for facebook to craw my site to correct the problem?
Regards
Dave
Crispo
3 Points
2013-12-29 12:22 pm EST
Hello Dave,

The image displayed on Facebook can be set using OpenGraph, but in my experiences it can be buggy from time to time. For more information on setting it with OpenGraph, you may view the following article on the Facebook developer site:

Facebook Developers - OpenGraph
JeffMa
9,162 Points
Staff
2013-12-30 10:42 am EST
Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!