Using a shared SSL with WooCommerce (for WordPress)

Category: Ssl

ericem
Asked:
2013-10-10 1:46 pm EST

Hits: 1,698
Hello,
I believe I understand how shared SSL works. However, I’m a little confused as to how to implement it with WordPress site, specifically WooComerce. In addition I am using an add-on domain which the url would look something like this in my case: https://secure139.inmotionhosting.com/~tyrane5/public_html/jenilife.

The issues I’m confused is where do I setup the username and password so I can log into/use the urls. From what I understand, the cert is there and as along as I point to the server (secure139) I can use it. One other question. How do I make sure what's on the cert matches the WHOIS. I have my domain at a different registrar and the privacy has been removed,

Thanks.
Eric Erickson

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

JeffMa
Staff
9,162 Points
2013-10-10 2:14 pm EST
To use the shared SSL, you would need to change your links within your Wordpress database to reflect the shared SSL so that your site uses the URL for the shared SSL instead of the domain. As there are several entries in the database from both Woocommerce as well as Wordpress that will reflect the old domain, your best option to do this would be to use a plugin such as the Wordpress search and replace plugin. From here, you will need to change all instances of your domain to the URL for the shared SSL.

Regarding the certificate information, this would not be able to be changed as it is a shared SSL and not your own dedicated SSL. The SSL information will display our information while you are using the shared SSL.

You must login before you can post a comment about this answer.

Ok, great. Thank you. The only other question I have is when I click on the link: https://secure139.inmotionhosting.com/~tyrane5/public_html/jenilife I get a prompt to enter a username and password. I don't seem to have one, or I must have not kept track of it. Alternatively, is this an issue (username/password login) that once I change the links to the shared SSL link that the login won't be an issue?
ericem
13 Points
2013-10-10 4:24 pm EST
It looks like you password protected your public_html directory with .htaccess. You would just need to remove the password protection either within your .htaccess file or from within cPanel. These articles will help you with that:

How do I password protect a directory in my control panel (cpanel)?
How to password protect a single file with htaccess

You will just need to remove the lines from your .htaccess file. It may also show within your cPanel under Password Protect Directories as well which you can remove it there.
JeffMa
9,162 Points
Staff
2013-10-10 4:43 pm EST
Like this Question?

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!