Server Internal Error

Category: Server Usage

Kenbower
Asked:
2013-01-14 11:16 am EST

Hits: 414
I get the following Error Message using FORMMAIL
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@kenbow5.kenbower.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Can anyone Help?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

JacobIMH
Staff
9,968 Points
2013-01-14 11:54 am EST
Hello Kenbower, and thank you for your question.

I took a look at your /cgi-bin/formmail.cgi script for you and it looks like it was a simple problem to resolve. Basically on line 40 in that file was this line:

@referers = ('example.com','74.124.198.61);

It was missing the last closing single quote ', I went ahead and added it so it looks like this now:

@referers = ('example.com','74.124.198.61');

I sent you a test message and it went through without issues now. (UPDATE: Well actually I checked the mail logs and the email itself didn't deliver even though the form successfully tried to send it. It looks like the email address you entered in your contact.htm file as the "recipient" input field isn't an actual email account on the server. So you need to either update it to a valid email account, or create the email account you have it currently sending to.)

Please let us know if you have any further questions at all, we'd be glad to lend you a hand!

- Jacob

You must login before you can post a comment about this answer.

0

jamesr
Staff
5,889 Points
2013-01-14 1:33 pm EST
Thank you for your question Kenbower!

Typically this error is caused by permissions or an .htaccess code that is preventing it from loading. Usually this is caused by the .pl file not being set to 755, Please see the following link of this.

How to set up FormMail

If this is not the case you will need our support to replicate the problem. Unfortunately, we cannot replicate this through the support center forum, because this is a public forum.

Please check with our support staff to get the login information to find the Internal server error. Please contact support by chat, or phone with the steps to replicate the problem. They will need account information like the domain on the account or the cpanel username and login credentials to check the script. Sorry for the inconvenience.

Regards,
James Richardson.

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!