How tdo I change PrestaShop virtual product size to 300MB?

Category: Prestashop 15

shimola
Asked:
2014-05-07 9:02 pm EST

Hits: 272
When I attempt to set the "Maximum size for a downloadable product" to greater than 128MB, I get "The limit chosen is larger than the server's maximum upload limit. Please increase the limits of your server."

I tried changing upload_max_filesize = 300M in /public_html/php.ini but that did not help.

What else do I change?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

Arn
Staff
18,399 Points
2014-05-07 9:36 pm EST
Hello Shimola,

Sorry to hear about your problem. The upload limit for a virtual product is a hard-coded number in a specific file. I'm not sure what version of PrestaShop that you're using so here are two solutions:

For version 1.6, please look at our article on Fixing the Error: "This file is missing" in PrestaShop 1.6

For version 1.5, you'll need to do the following:

  1. Open up cPanel and the click on the file manager icon

  2. Navigate to the folder that contains your PrestaShop installation. If you loaded PrestaShop using the primary domain of your account, then the default folder you'll need to find is PUBLIC_HTML.

  3. Once you're in the folder, look for a folder named "config", then click on it to open it.

  4. Next look for a file named config.inc.php. Click on the file and then select EDIT from the menu at the top of the file manager -you can also right-click and select EDIT (or Code edit).

  5. Look for this line of code: ini_set('upload_max_filesize', '100M'); and then change the limit to the size that you need.


  6. SAVE the changes


  7. That should take care of the upload size limit issue. If you're still having problems, then please leave more details on the problem and we would happy to look into it for you.

    Regards,
    Arnel C.

    You must login before you can post a comment about this answer.

    Hey, sorry. I have PrestaShop 1.6 installed. I made each of the following changes, but no luck with setting the "Maximum size for a downloadable product " bigger than 128MB.
    ***********
    php.ini
    ***********
    ; Maximum size of POST data that PHP will accept.
    post_max_size = 300M

    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 300M

    ***********
    classes/uploader.php
    ***********
    const DEFAULT_MAX_SIZE = 524288000;

    ***********
    config.inc.php
    ***********
    ini_set('upload_max_filesize', '300M');

    shimola
    8 Points
    2014-05-08 9:32 pm EST
    Hello Shimola,

    While all your size settings should allow you to have file size uploads larger than 128MB, there is a server security setting that does not allow uploads in php scripts. Unfortunately, that is a security rule that is unable to be removed on a per user basis. The only hosting plans we have that can handle files that large are the VPS and Dedicated servers. You may also try to zip the file and see if it compresses it below the 128MB limit. This may work for you.

    Kindest Regards,
    Scott M
    Scott
    20,848 Points
    Staff
    2014-05-09 5:53 pm EST
Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!