Credit Card Processing Problem Prestshop and First Data

Category: Prestashop 15

InMotionFans
n/a Points
Asked:
2013-10-03 8:08 am EST

Hits: 325
I am having an issue with credit card processing. All payments are going through, but the trouble is that, when my client tests it using a credit card and intentionally uses an incorrect CVV number AND/OR Exp Date to test it, the purchase STILL goes through. (A side note: I just tried testing a credit card. I purchased one item. Proceeded to checkout (non-registered use). My first test purchase DID go through WITH a bad CVV number. BUT my other test did NOT go through using bad Exp Date.)

I think there is something in the settings that I need to change, but don't know what to do. I'm wondering if the settings for AVS and/or CVV2 for First Data are too high or too low? OR, if the PrestaShop settings in the backend are too high or too low.

I spoke with First Data and they told me that the site is not configured properly to send info to gateway. They said my shopping cart is not sending the AVS or CVV2 info along with the transaction to the gateway, then, ultimately to card issuing bank. Since the transaction info is not there, the bank has nothing to verify, then it sends it as "not available" back to the gateway.

I am currently using PS version 1.5.4.1 and have asked the theme developer if upgrading to 1.5.5.0 will help. He does not guarantee it, but said it is worth a try. I hired a developer to help me with this site a few weeks ago (he is very good and has 9 years of PS experience), but he cannot seem to resolve the issue described.

The module we are using is the default module that came with PS: First Data 1.2.1. We are also using an appointment booking module and I wonder if that is the source which is creating the javascript issues. I've had a few other developers glance at the site and they all seem to agree that it is a JS problem.

Thank you for any help you can offer!

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

Scott
Staff
16,652 Points
2013-10-03 9:35 am EST
Hello,

Thank you for your question. Unfortunately we are unable to test that specific issue, so the most information we have is from searching around the web. So far that has not returned anything of value.

Please keep checking back and if we discover something we will be happy to add it to the responses. Likewise, if you run across an answer as wellm, please let us know so we can help others who may have the same issue.

Kindest Regards,
Scott M

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!