InMotion Hosting Support Center

Is there a workaround for Moodle 2.2.1 for php 5.3?

Category: Moodle

2012-02-29 6:51 am EST

Hits: 3,700
I tried to install Moodle (currently version 2.2.1) through Fantastico. After installation is completed, I went to the site. however, I only get the following error messages:

"Moodle 2.1 or later requires at least PHP 5.3.2 (currently using version 5.2.17).
Please upgrade your server software or install older Moodle version."

How can I fix this error? Or, is there a workaround?

*I looked at the post on how to edit the lib.php file that should work for Moodle 2.1. However, it does not apply in Moodle 2.2.

Thanks for your help!

You must login before you can ask a follow up question.

You must login before you can submit an answer.



Tim S.
9,967 Points
2012-02-29 8:56 am EST
Hi eNousk,

Thanks for posting your question. I'm more than happy to assist you. While I have not installed the latest version of Moodle, the tutorial for the workaround for Moodle 2.1 should work as well. Here's a link to it:

Moodle requires PHP 5.3 Workaround

Alternatively, our latest servers have PHP 5.3 installed and you can ask to be moved to a server that meets those requirements. If you want to be moved to another server, you'll need to submit an email to In the email be sure to provide verification for your account. Verification consists of the last four digits of the credit card on file or the current AMP password.

If you need further assistance please feel free to contact us.


Tim S

You must login before you can post a comment about this answer.

Like this Question?

Support Center Login

Social Media Login

Social Login Joomla

Related Articles

Need more Help?


Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!