Joomla v 3.1.5 SEF not working

Category: Joomla 3

InMotionFans
n/a Points
Asked:
2013-12-24 1:57 am EST

Hits: 1,117
alwaysbeready.com website. I am helping my friend Chalrie Campbell move his website onto inmotionhosting on a vps. So far the website is up and running, however when we turn SEF on in the global configuration, like we had it on at the previous hosting location, we get 404 errors. Something is different here on this server and we need some help to make it work again.

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

JeffMa
Staff
9,479 Points
2013-12-24 9:03 am EST
It sounds like you have not copied your .htaccess file from the previous host over. As the .htaccess file is a hidden file, you will need hidden files enabled on the previous host to view it. The .htaccess file contains the necessary informatin for mod_rewrite to create search engine friendly URLs on your site. If you are unable to find it on the previous host for some reason, you may also obtain it from your htaccess file that is located in the Joomla installation package for your particular version. In may versions of Joomla, it is name htaccess.txt which you would need to rename to .htaccess.

You must login before you can post a comment about this answer.

0

JacobIMH
Staff
9,968 Points
2013-12-24 4:03 pm EST
Hello, and thanks for your question.

It does look like you were missing your hidden .htaccess file for your Joomla site, and this was causing the 404 errors when you turned on Search Engine Friendly URLs. I could see on the VPS that you were getting 404 errors from search engines, so it was obvious that you had good links out there indexed already using this format of URL and so it was working with your old host.

I went ahead and in the meantime copied the default Joomla htaccess.txt file from GitHub onto your VPS and re-named it .htaccess. I also went ahead and turned on SEF in your configuration.php file with the public $sef = '1'; option.

I left the original copies of both these files in place as .htaccess-BAK, and configuration.php-BAK in case you wanted to revert it. But I see now that when you click on one of your links the SEF format URLs are working properly so that's probably what you'd want left in place.

Hope that works for you, let us know if you're having any other issues.

Happy Holidays!

- Jacob

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Joomla Community Google+ Hangout #3

June 3rd, 2014

Thank you @RustyJoomla for letting me speak on the Joomla Community Google+ Hangout!

Click here to watch!

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!