InMotion Hosting Support Center

How to increase PHP memory allocation to 64MB

2013-07-20 3:15 am EST

Hits: 2,419
I'm building a Wordpress web site. It requires at least 64MB for the PHP memory allocation. But currently it is 40MB by default. How can I increase it? Thanks!

You must login before you can ask a follow up question.

You must login before you can submit an answer.



19,008 Points
2013-07-22 12:01 pm EST
Hello tony_chen,

Thank you for your question. You can view your current PHP settings using a PHP info page. If you want to increase your PHP memory from 40MB to 64MB, you must modify the php.ini file.

Here is a link to our guide on how to update your PHP settings.

You can also make these rules affect all website in your account, by making it recursive.

If you have any further questions, feel free to post them below.
Thank you,


You must login before you can post a comment about this answer.

Thank you for your reply. By running phpinfo.php, I found the php memory limit has already been set to 512MB on the server. After I added a line "define('WP_MEMORY_LIMIT', '256M');" to the file wp_config.php, the problem was solved! Now, there is no red warning message on the server status page. Thanks!
8 Points
2013-07-22 11:57 pm EST
Like this Question?

Need more Help?


Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail:
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!