building ffmpeg with --enable-shared


edwardsmarkf
Asked:
2011-11-22 3:09 pm EST

Hits: 11,230

hi -

i can build a new ffmpeg no problems but when i try to do one with shared-enabled:

./configure --shared-enabled ;
make;

i get this error (below)

any ideas?

thanks!


# make
LD libavutil/libavutil.so.51
/usr/bin/ld: libavutil/intfloat_readwrite.o: relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
libavutil/intfloat_readwrite.o: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libavutil/libavutil.so.51] Error 1

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Best answer chosen by InMotion Hosting staff

0

Tim S.
Staff
9,967 Points
2011-11-22 4:02 pm EST
Hi edwardsmarkf,

thanks for posting your question. We're looking into this for you and will post a comment when we have further information.

If you need further assistance please feel free to contact us.

Thanks!

Tim S

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!