InMotion Hosting Support Center

Why does my favicon not work on my website?

Category: File Management

suncoaster77
Asked:
2012-02-11 3:21 am EST

Hits: 10,477
Hello,

my favicon does not work.
First I uploaded a finished favicon.ico file to the root public_html folder. As it did not appear, I tried to upload a jpg-file and rename it to .ico as mentioned in the tutorial. Did not work again.
Just to make sure, I uploaded the favicon.ico also to the very root directory, but it does not appear.

The link I am using in my html-file looks like this: an I added type="image/x-icon" / inside the tag when I used the .jpg-file.

What did I do wrong? What (root) folder does the .ico-file have to be stored in? Any comments on the tag?

Thanks in advance!

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Hi,

I am also having trouble with my favicon. I am getting many /favicon.ico under pagenot found.
UniqJDsgn
0 Points
2014-01-03 03:20 pm EST
<div style="background-color: #FFF; padding-left: 10px;">Hello UniqJDsgn,

It appears that your website has a lot of requests for <strong>/img/favicon.ico?1387689441</strong>. If you follow our guide on <a href="http://www.inmotionhosting.com/support/website/how-to/how-to-create-a-favicon-for-your-website" target="_blank">how to add a Favicon for your website</a> you should see that you'd typically want to end up with a link like this in your website's source code:

<pre class="code_block" style="width: 500px; white-space: normal; margin-bottom: -30px;">&lt;link rel='shortcut icon' href='favicon.ico' type='image/x-icon' /&gt;</pre>

I'd double-check your settings in PrestaShop to see what might be adding that extra content onto the end of your image. However it looks like the Favicon itself is showing up on your website, but I do see 404'd requests for <strong>favicon.ico</strong>. This is because you don't have that file in your main <strong>/public_html/</strong> directory, but rather inside the <strong>/public_html/img</strong> directory.

To stop the 404 errors, you can either simply copy your <strong>favicon.ico</strong> file to your main <strong>/public_html/</strong> directory, or correct the linking on certain pages to go to the <strong>/public_html/img</strong> one.

Please let us know if you had any further problems at all.

- Jacob</div>
JacobIMH
9,968 Points
2014-01-03 03:58 pm EST

OTHER ANSWERS

0

Tim S
Staff
11,055 Points
2012-02-13 11:46 am EST
Hi suncoaster77,

Thanks for posting your question. I'm more than happy to assist you. I've looked over your website and it appears the favicon loads as expected. It appears a green square with a leaf cut out of the center. Are you still having issues with your favicon? If so, what website/ folder are you working in?

Also, try clearing your web browser cache and see if that corrects the issue.

If you need further assistance please feel free to contact us.

Thanks!

Tim S

You must login before you can post a comment about this answer.

Like this Question?

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!