Drupal Commons (current version) can't send system generated emails

Category: Drupal 7

InMotionFans
n/a Points
Asked:
2014-07-30 6:57 pm EST

Hits: 34
I have installed Drupal Commons on two of my sites, www.canuckcoffee.com and www.digitalcanuck.com and after install there was an error message: Unable to send e-mail. Contact the site administrator if the problem persists.

There are no email configuration settings in Drupal Commons to change anything other than the email address where system emails are to be sent from. Is there a system configuration on the server which is stopping this distribution from working. In both cases, the distributions have been upgraded to the most current version of Drupal Commons 3.16. They are both plain jane installs, no changes, no extra data other than the sample data. Any ideas? I've not found this to be problem via googling so

I'm thinking it's a server setting???

thanks,
Rick

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

JacobIMH
Staff
9,968 Points
2014-07-30 7:21 pm EST
Hello Rick, and thank you for your question.

I'm not 100% yet what's going on, did you happen to modify your php.ini file on your account earlier today while trying to get the PHP mail functioning?

For now I've gone ahead and re-named your /public_html/php.ini file to php.ini-BAK so that the server's default PHP settings are used instead, and that seems to allow PHP mail to function like normal again.

I just had another customer with the same issue less than an hour ago, so I was thinking this might be related to something our senior system administration team is attempting to do with updates to PHP. I've gone ahead and reached out to them to see if this is the case.

Please let us know if you're still seeing any issues at the moment with your Drupal generated emails.

- Jacob

You must login before you can post a comment about this answer.

Yes, I created a php.ini file as the system one did not allow for a long enough time for max_execution_time = 120 . Once I created and uploaded the php.ini I could install the software. Thanks for fixing it. but if I have to re-install the software - which I likely will, I'll have to put the php.ini in play to get the install, then disable it. Can you modify the system php.ini?
thanks,
Rick
CanuckCoffee
3 Points
2014-07-30 8:16 pm EST
Hello again Rick,

Thanks for getting back and letting me know what was going on. We can't modify the system php.ini file directly on a shared server, but what I've gone ahead and done for you is just placed a full copy in your /public_html directory so now it retains this important setting which yours was missing that affected the mail() function:

sendmail_path = "/usr/sbin/sendmail -t -i"

I went ahead and also already set max_execution_time = 120 in that file for you as well.

So this should allow you to still make any PHP modifications you need to make, but keep the other default stuff the server had setup already working as well.

- Jacob
JacobIMH
9,968 Points
Staff
2014-07-30 11:26 pm EST
Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!