Clean URLs in Drupal 7 - Generating 404 Errors

Category: Drupal 7

M_bus
Asked:
2012-10-06 4:30 pm EST

Hits: 1,924
I installed Drupal 7 from the cPanel and went through playing around with it, trying to learn what I was doing. I installed Chaos Tools and Views (my only two third-party modules I installed).

Then I tried to enable clean URLs. The clean URL test told me that I was not allowed to enable, so I followed the documentation and uncommented the line in .htaccess that reads:
RewriteBase /

Now the clean URL test says that I am allowed to use clean URLs. But when I enable, it sends me to the default inMotion 404 page that just says "your IP address is XXX.XXX.XXX.XXX". I can load my homepage (no doubt because it's not trying to replace the '?q=' argument in any URL), but I can't access the admin menu.

I was able to turn clean URLs off again (by just entering the web address /domain/?q=admin/config/search/clean-urls and turning it off that way). But I would LIKE to be able to use clean URLs. I've been going through documentation all day and can't figure out what could be doing it.

No edits to my htaccess file have worked so far. I have messed with the following options:
Options +FollowSymLinks
Options -Indexes

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !=/favicon.ico
RewriteRule ^ /index.php [L]


but none of these have done much (no matter what I've done to them).

Am I missing something? Has anyone else had this problem? If so, how did you fix it? Perhaps I overlooked something as a result of browser caching and I fixed it at some point. Anyway, I've been at it scouring the Drupal forums for a few hours and no luck.

UPDATE: Viewing the logs (still learning, otherwise I'd have checked this sooner), I note that the mkdir() command is being denied permission. I SUSPECT that this is related to some file beyond my control (httpd.conf? Is InMotion running Apache?) Is there a workaround?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

Best answer chosen by User

0

Scott
Staff
19,557 Points
2012-10-08 9:56 am EST
Hello M_bus,

I have a installed a fresh version of Drupal 7.15 on my server. I also downloaded and activated both the Chaos Tools and Views modules to emulate your setup. I had no issue with enabling the Clean URLs for the installation.

I also checked both htaccess files (yours and mine) side by side. The only difference is line 105 where you have:
RewriteRule ^ /index.php [L]

and the test install has:
RewriteRule ^ index.php [L]

Try setting your version to the one from the test install. If that is unsuccessful, there may be some other setting that is involved. I would try and remove the installation and re-install it to see if that helps.

If not, then you may want to allow us to take a look from your side of things. We would need a bit of information from you, namely the Drupal Admin and password. You can send the specific information to docs@inmotionhosting.com Be sure to validate your account with either the last 4 digits of the credit card on file, or the current Account Management Panel (AMP) password. As we do not actively monitor that address, be sure to leave a comment below so we know the information was sent.

Best Regards,
Scott M

You must login before you can post a comment about this answer.

Like this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!
Ask a Question

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!